WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] V6.3 gnome-terminal missing dependency? libepoxy  (Read 5219 times)

gordon64

  • Guest
[SOLVED] V6.3 gnome-terminal missing dependency? libepoxy
« on: June 28, 2015, 06:19:57 AM »
just installed gnome-terminal
wbar icon appears but fails
here is terminal results if relevant?

Code: [Select]
tce-load -i gnome-terminal
at-spi2-core.tcz: OK
at-spi2-atk.tcz: OK
gtk-query-immodules-3.0: error while loading shared libraries: libepoxy.so.0: cannot open shared object file: No such file or directory
gtk3.tcz: OK
vte.tcz: OK
dconf.tcz: OK
warning: Schema 'org.gnome.system.locale' has path '/system/locale/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy' has path '/system/proxy/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.http' has path '/system/proxy/http/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.https' has path '/system/proxy/https/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.ftp' has path '/system/proxy/ftp/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.socks' has path '/system/proxy/socks/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
gsettings-desktop-schemas.tcz: OK
libcroco.tcz: OK
librsvg.tcz: OK
gnome-icon-theme.tcz: OK
gnome-icon-theme-symbolic.tcz: OK
gnome-themes-standard.tcz: OK
warning: Schema 'org.gnome.system.locale' has path '/system/locale/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy' has path '/system/proxy/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.http' has path '/system/proxy/http/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.https' has path '/system/proxy/https/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.ftp' has path '/system/proxy/ftp/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.socks' has path '/system/proxy/socks/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
gnome-terminal.tcz: OK

ok lets load libepoxy

Code: [Select]
tce-load -i libepoxy
libepoxy.tcz: OK
tc@box:~$ sudo rm /usr/local/tce.installed/gnome-terminal
tc@box:~$ tce-load -i gnome-terminal
warning: Schema 'org.gnome.system.locale' has path '/system/locale/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy' has path '/system/proxy/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.http' has path '/system/proxy/http/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.https' has path '/system/proxy/https/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.ftp' has path '/system/proxy/ftp/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.socks' has path '/system/proxy/socks/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
gnome-terminal.tcz: OK

second wbar icon appears.....terminal now opens

going into to preferences...shortcuts or encodings causes immediate crash

2)  photo is brighter than actual brightness of font.....font is too faint
I have never used gnome-terminal ....spoilt with other terminals so umm this is not a big issue for me
I will let others decide to tell me how to fix

I am reporting a possible missing dependency.

FYI


« Last Edit: August 15, 2021, 08:49:23 AM by Rich »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14488
Re: V6.3 gnome-terminal missing dependency? libepoxy
« Reply #1 on: June 29, 2015, 12:31:18 AM »
Are you using Xfbdev? With Xorg-7.7 I don't see the missing libepoxy dep and gnome-terminal doesn't crash with preferences/encodings or preferences/shortcuts.

Note that there are issues with later versions of gnome-terminal that will not work without a utf-8 local being set - maybe earlier versions crash when a utf-8 local is set?

gordon64

  • Guest
Re: V6.3 gnome-terminal missing dependency? libepoxy
« Reply #2 on: June 29, 2015, 03:05:30 AM »
Hi

actually got into 64 rebuild quicker than I thought.

Quote
Are you using Xfbdev? With Xorg-7.7
  No standard FLWM for the moment.

2) but I had not set up locale so here are new results....for code box
Code: [Select]
locale
LANG=en_AU.UTF-8
LC_CTYPE="en_AU.UTF-8"
LC_NUMERIC="en_AU.UTF-8"
LC_TIME="en_AU.UTF-8"
LC_COLLATE="en_AU.UTF-8"
LC_MONETARY="en_AU.UTF-8"
LC_MESSAGES="en_AU.UTF-8"
LC_PAPER="en_AU.UTF-8"
LC_NAME="en_AU.UTF-8"
LC_ADDRESS="en_AU.UTF-8"
LC_TELEPHONE="en_AU.UTF-8"
LC_MEASUREMENT="en_AU.UTF-8"
LC_IDENTIFICATION="en_AU.UTF-8"
LC_ALL=
tc@box:~$ tce-load -i gnome-terminal
at-spi2-core.tcz: OK
at-spi2-atk.tcz: OK
gtk-query-immodules-3.0: error while loading shared libraries: libepoxy.so.0: cannot open shared object file: No such file or directory
gtk3.tcz: OK
vte.tcz: OK
dconf.tcz: OK
warning: Schema 'org.gnome.system.locale' has path '/system/locale/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy' has path '/system/proxy/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.http' has path '/system/proxy/http/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.https' has path '/system/proxy/https/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.ftp' has path '/system/proxy/ftp/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.socks' has path '/system/proxy/socks/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
gsettings-desktop-schemas.tcz: OK
libcroco.tcz: OK
librsvg.tcz: OK
gnome-icon-theme.tcz: OK
gnome-icon-theme-symbolic.tcz: OK
gnome-themes-standard.tcz: OK
warning: Schema 'org.gnome.system.locale' has path '/system/locale/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy' has path '/system/proxy/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.http' has path '/system/proxy/http/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.https' has path '/system/proxy/https/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.ftp' has path '/system/proxy/ftp/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.socks' has path '/system/proxy/socks/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
gnome-terminal.tcz: OK
tc@box:~$ tce-load -i libepoxy
libepoxy.tcz: OK

terminal no longer crashes......but for FLWM I allege font brightness is so bad its usuable.....on FLWM

Have not tested Xorg yet and yes I know most 64 bit users "likely" to be on it.

Mark it as solved please. I hope to have another terminal submitted in a week or so.
for now I am using aterm.

and thanks for that.

gordon64

  • Guest
Re: V6.3 gnome-terminal missing dependency? libepoxy
« Reply #3 on: June 29, 2015, 03:39:10 AM »
sorry one more feedback.....just rebooted with Xorg and no config file.....maybe I need one...buts thats a matter for me to sort out

here is proof of xorg, I hope as we now have pretty colours and same faint font.

2) I was unable to untick the UTF-8 encodings....but as I said I am not experienced with gnome-terminal so not fussed either way on that issue.



thanks for reading

gordon64

  • Guest
Re: V6.3 gnome-terminal missing dependency? libepoxy
« Reply #4 on: July 22, 2015, 06:13:55 AM »
Hi

I now think that its not gnome-terminal that has a missing dependency but instead its gtk3 itself?

Code: [Select]
tce-load -i gtk3
at-spi2-core.tcz: OK
at-spi2-atk.tcz: OK
gtk-query-immodules-3.0: error while loading shared libraries: libepoxy.so.0: cannot open shared object file: No such file or directory
gtk3.tcz: OK
#####################
tce-load -i libepoxy
libepoxy.tcz: OK
sudo rm -rf /usr/local/tce.installed/gtk3
tce-load -i gtk3
gtk3.tcz: OK
###############
cat /etc/sysconfig/Xserver
Xfbdev

I am aware I can not remove my above posts, but if you agree can you look at attempting to duplicate this on a standard FLWM onboot list please-----when you get a chance?

forgive me if I am wrong again and yes I do understand that most people choosing X86_64 are more likely to be running Xorg but I am still booting up into a simple fluxbox with Xfbdev.

 :-[

cheers


« Last Edit: July 22, 2015, 06:19:22 AM by gordon64 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14488
Re: V6.3 gnome-terminal missing dependency? libepoxy
« Reply #5 on: July 22, 2015, 09:15:28 AM »
libepoxy is a dependency of Xorg - Xbdev behaves weirdly on my hardware so I don't often use it - when I get chance, I'll test with flwm/Xfbdev and adjust as required.

gordon64

  • Guest
Re: V6.3 gnome-terminal missing dependency? libepoxy
« Reply #6 on: July 24, 2015, 03:29:21 AM »
OK well I have now found a way of swapping between my xorg and xbase LISTS without as many graphic issues I was having in the past.

that is....before I reboot or shutdown I now delete .Xauthority and .xsession
I am aware of the shutdown script but just mentioning it as it was the main reason why I was spitting the dummy above.

I no longer need you to do a xbase test as I now know you may have some graphic issues as well.

To finalise this post, with luck, here is an independent test showing booted up into xorg with a lang of UTF8 set and no libepoxy errors showing in loading gnome-terminal.

Lets mark this one as solved? and thanks for your patience.



cheers