WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Build a new version based on raspberry kernel 4  (Read 6667 times)

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Build a new version based on raspberry kernel 4
« Reply #15 on: August 19, 2015, 09:05:49 AM »
Hi Rich,

Thank's a lot. You're right. I've overseen that binutils.tcz is not included in the compile-essentials.tcz.dep and therefor is not automatically installed. Now it works.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11157
Re: Build a new version based on raspberry kernel 4
« Reply #16 on: August 19, 2015, 09:37:39 AM »
Hi jgrulich
Quote
I've overseen that binutils.tcz is not included in the compile-essentials.tcz.dep ...
True, but  gcc.tcz  is listed and it depends on  binutils.tcz  as shown in the  compile-essentials.tcz..tree  file:
Code: [Select]
compile-essentials.tcz
   autoconf.tcz
      perl5.tcz
   automake.tcz
      autoconf.tcz
         perl5.tcz
   glibc_base-dev.tcz
   glibc_apps.tcz
   glibc_add_lib.tcz
   glibc_gconv.tcz
   file.tcz
   gcc.tcz
      gcc_base-dev.tcz
      gcc_libs-dev.tcz
         gcc_libs.tcz
      binutils.tcz
      cloog.tcz
         isl.tcz
            gmp.tcz
      mpc.tcz
         mpfr.tcz
            gmp.tcz
   libtool.tcz
      libltdl.tcz
   m4.tcz
   make.tcz
   patch.tcz

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Build a new version based on raspberry kernel 4
« Reply #17 on: August 19, 2015, 12:37:27 PM »
Apparently i have different dependeny tree for gcc and the binutils and some other are not listed there.
I'm using gcc.tcz Rev. 5.2.0 which is dated 2015/08/13. It's dependent only on isl.tcz and mpc.tcz.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11157
Re: Build a new version based on raspberry kernel 4
« Reply #18 on: August 19, 2015, 02:11:16 PM »
Hi jgrulich
The tree file I post was from TC6, I guess you're using TC7. I'm not sure why that was left out. I was under the impression that
gcc converts code to assembly and then assembles it.

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Build a new version based on raspberry kernel 4
« Reply #19 on: August 20, 2015, 02:47:24 AM »
Yes, I'm using TC7.0 4.1.6-piCore_v7+.

Béla, please be so kind and update the dep for gcc.

Regards,

Jan

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Build a new version based on raspberry kernel 4
« Reply #20 on: September 06, 2015, 03:29:06 AM »
Hi just for your info. I analyzed the differences between a default raspbian .config and the .config that Bela is using for building piCore for RPI2 (kernel 4.1.6).
So the following is what needs to be changed in a default .config:
Code: [Select]
CONFIG_LOCALVERSION="-piCore_v7"
CONFIG_ZSWAP=y
CONFIG_ZPOOL=y
CONFIG_ZSMALLOC=y
CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
CONFIG_ZRAM=y
CONFIG_BLK_DEV_PMEM=m
# CONFIG_SND_SOC_ADAU1701 is not set
CONFIG_RTC_DRV_ABB5ZES3=m
CONFIG_RTC_DRV_ABX80X=m
CONFIG_RTC_DRV_HYM8563=m
CONFIG_RTC_DRV_PCF85063=m
CONFIG_RTC_DRV_DS1343=m
CONFIG_RTC_DRV_DS1347=m
CONFIG_RTC_DRV_MCP795=m
CONFIG_EXT4_ENCRYPTION=y
CONFIG_EXT4_FS_ENCRYPTION=y
CONFIG_SQUASHFS=y
CONFIG_SQUASHFS_LZ4=y
CONFIG_SQUASHFS_4K_DEVBLK_SIZE=y
CONFIG_ENCRYPTED_KEYS=y
CONFIG_CRYPTO_RNG=y
CONFIG_CRYPTO_GF128MUL=y
CONFIG_CRYPTO_CTS=y
CONFIG_CRYPTO_ECB=y
CONFIG_CRYPTO_XTS=y
CONFIG_CRYPTO_HMAC=y
CONFIG_CRYPTO_SHA256=y
CONFIG_CRYPTO_LZO=y
CONFIG_LZ4_COMPRESS=y
CONFIG_SND_SOC_SIGMADSP=m

CONFIG_SND_SOC_SIGMADSP_I2C=m

For my own purpose I will add:
CONFIG_CROSS_COMPILE="/cross/tools-master/arm-bcm2708/arm-bcm2708hardfp-linux-gnueabi/bin/arm-bcm2708hardfp-linux-gnueabi-"
CONFIG_SND_USB_HIFACE=m

Regards
Steen