WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: new to linux - No Wifi  (Read 6206 times)

Offline potticous

  • WikiUser
  • *
  • Posts: 15
new to linux - No Wifi
« on: December 03, 2013, 11:21:50 AM »
I like the look of TinyCore and have chosen it over Slax 7.0.8, Puppy Linux 5.7.1 and Slitaz 4.0, all put me off after finding a single problem  ;D But i'm sticking with TinyCore core because i can feel the greatness.

Problem is, i can't load wifi. I've read nearly everything on getting it to work but it won't. I installed it to include wifi support + firmware, tried commands etc in the terminal, and got nowhere with "RunApp".

Back to square one now, help!

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: new to linux - No Wifi
« Reply #1 on: December 03, 2013, 12:00:08 PM »
Hi

using Apps you can install Wifi.tcz extension 

it would help then to type this command at the terminal 

dmesg | tail -50 > dmesg.log

then attach the txt file  here to help anyone advise further

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: new to linux - No Wifi
« Reply #2 on: December 03, 2013, 01:45:27 PM »
Depending on WIFI adapter additional firmware extension may be required.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: new to linux - No Wifi
« Reply #3 on: December 03, 2013, 04:15:47 PM »
I am surprised how many Realtek wifi devices are now supported in kernel 3.8.13,  as bmarkus stats all that you may need is firmware.  posting the output of the above command will help with that too


Offline potticous

  • WikiUser
  • *
  • Posts: 15
Re: new to linux - No Wifi
« Reply #4 on: December 04, 2013, 05:29:20 AM »
sorry for taking so long...

I tried running Wifi.cz but theres no reponse.
Using the Live CD, without wifi i cant browse apps, and when i search locally nothing appears. But from the USB (nowformatted ::)) a few wifi apps appeared locally but a message says something like they can't run/be found.

Quote
dmesg | tail -50 > dmesg.log

This symbol doesn't appear in the terminal, i ran "dmesg" but coulnd't copy and paste the results using script editor.

Im computer literate but linux is rendering me useless  >:( BTW im using the CorePlus5.1 ISO, is it normal that when TC is loading its say 3 times that it can't load what seem to be the wifi + firmware tcz's???

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: new to linux - No Wifi
« Reply #5 on: December 04, 2013, 08:43:34 AM »
Alternatively you can boot with code "syslog" and attach /var/log/messages instead.
By priority you should fix whatever is wrong with your bar character, as it is of major importance for shell language.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: new to linux - No Wifi
« Reply #6 on: December 04, 2013, 11:11:49 AM »
Leaning how to get around Linux is fun huh?  I'm sure you'll find the experience rewarding so keep at the grindstone, you'll get there in the end.

To help you with WiFi support it's important to know basic information regarding the Wifi chip on your device.

In most keyboards the | key is typed with Shift + \ keys.   

Selecting (highlighting) with the cursor copies text (nothing more than that is required in most cases), then using either the middle mouse button or both left + right mouse buttons simultaneously will paste the text.  try that..

Your hardware may result in similar output.  You may notice the device here is rtl8192cu, the driver requires  firmware rtl8192cufw.bin which may be found in rtlwifi .  This firmware is available in " firmware-rtlwifi.tcz " and can be loaded using Apps

type dmesg at the terminal

If this (or similar) is all you see after inserting your USB WiFi adapter and refreshing dmesg, then the device has no driver installed (and may not be supported)
Code: [Select]
[  166.536739] usb 2-4: new high-speed USB device number 4 using ehci-pci


If this (or similar) is printed after inserting your USB WiFi adapter and refreshing dmesg, then the device is supported but requires firmware.   
Code: [Select]
[  146.786744] usb 2-4: new high-speed USB device number 5 using ehci-pci
[  146.930851] cfg80211: Calling CRDA to update world regulatory domain
[  146.939939] rtl8192cu: Chip version 0x10
[  147.024464] rtl8192cu: MAC address: 34:25:47:c3:5f:6a
[  147.024473] rtl8192cu: Board Type 0
[  147.024711] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1
[  147.024776] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin
[  147.024940] usbcore: registered new interface driver rtl8192cu
[  147.027839] rtlwifi: Firmware rtlwifi/rtl8192cufw.bin not available


The result of loading the appropriate firmware (in this case using Apps to install " firmware-rtlwifi.tcz "), re-inserting the device and refreshing dmesg, should be similar to
Code: [Select]
[  146.930851] cfg80211: Calling CRDA to update world regulatory domain
[  146.939939] rtl8192cu: Chip version 0x10
[  147.024464] rtl8192cu: MAC address: 34:25:47:c3:5f:6a
[  147.024473] rtl8192cu: Board Type 0
[  147.024711] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1
[  147.024776] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin
[  147.024940] usbcore: registered new interface driver rtl8192cu
[  147.027839] rtlwifi: Firmware rtlwifi/rtl8192cufw.bin not available
[  622.673667] usb 2-4: USB disconnect, device number 5
[  622.673847] rtlwifi: reg 0x102, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x80208a00
[  622.673859] rtlwifi: reg 0x422, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x80208a00
[  622.673871] rtlwifi: reg 0x542, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x20
[  622.673888] rtlwifi: reg 0x824, usbctrl_vendorreq TimeOut! status:0xffffffed value=0x80
[  626.610029] usb 2-4: new high-speed USB device number 6 using ehci-pci
[  626.735712] rtl8192cu: Chip version 0x10
[  626.818493] rtl8192cu: MAC address: 34:25:47:c3:5f:6a
[  626.818502] rtl8192cu: Board Type 0
[  626.818727] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1
[  626.818837] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin
[  626.824974] ieee80211 phy1: Selected rate control algorithm 'rtl_rc'
[  626.825583] rtlwifi: wireless switch is on

Now use the Wifi application to connect to your Access point (router)
« Last Edit: December 04, 2013, 11:26:21 AM by coreplayer2 »

Offline potticous

  • WikiUser
  • *
  • Posts: 15
Re: new to linux - No Wifi
« Reply #7 on: December 04, 2013, 11:29:52 AM »
My bad, when i mentioned the USB i meant using a TinyCore Live USB (still keep the info there, someone will use it) . Other tips noted... ill check it out.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: new to linux - No Wifi
« Reply #8 on: December 04, 2013, 11:52:12 AM »
The info above is generic for those new to Linux WiFi indicating what to look for, procedure is similar whether a USB or internally installed device.  That should be enough to help get you on the right track otherwise we still need chip specific information to assist further..   
« Last Edit: December 04, 2013, 11:54:40 AM by coreplayer2 »

Offline potticous

  • WikiUser
  • *
  • Posts: 15
Re: new to linux - No Wifi
« Reply #9 on: December 04, 2013, 02:43:16 PM »
heres what i retrieved:

Code: [Select]
Netfilter messages via NETLINK v0.30.
nfnl_acct: registering with nfnetlink.
IPv4 over IPv4 tunneling driver
IPv4 over IPSec tunneling driver
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP: cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17
NET: Registered protocol family 15
Key type dns_resolver registered
Using IPI No-Shortcut mode
registered taskstats version 1
rtc_cmos 00:03: setting system clock to 2013-12-04 22:15:17 UTC (1386195317)
Freeing unused kernel memory: 496k freed
Write protecting the kernel text: 3872k
Write protecting the kernel read-only data: 980k
input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/in  t4
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:01:00.0: irq 43 for MSI/MSI-X
r8169 0000:01:00.0 eth0: RTL8105e at 0xf805a000, f0:de:f1:c3:9e:e5, XID 00a000   IRQ 43
input: PC Speaker as /devices/platform/pcspkr/input/input5
microcode: CPU0: patch_level=0x03000014
loop: module loaded
wmi: Mapper loaded
ACPI: Deprecated procfs I/F for AC is loaded, please retry with CONFIG_ACPI_PR  FS_POWER cleared
ACPI: AC Adapter [ADP1] (on-line)
Adding 763888k swap on /dev/zram0.  Priority:-1 extents:1 across:763888k SS
squashfs: version 4.0 (2009/01/31) Phillip Lougher
usb 2-1: new high-speed USB device number 2 using ehci-pci
microcode: failed to load file amd-ucode/microcode_amd.bin
microcode: CPU1: patch_level=0x03000014
microcode: CPU2: patch_level=0x03000014
microcode: CPU3: patch_level=0x03000014
microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter  ruba
input: Ideapad extra buttons as /devices/platform/ideapad/input/input6
ACPI: Deprecated procfs I/F for battery is loaded, please retry with CONFIG_AC  _PROCFS_POWER cleared
ACPI: Battery Slot [BAT0] (battery present)
acpi device:37: registered as cooling_device4
ACPI: Video Device [VGA1] (multi-head: yes  rom: no  post: no)
input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/in  t/input7
acer_wmi: Acer Laptop ACPI-WMI Extras
acer_wmi: Brightness must be controlled by acpi video driver
input: Acer BMA150 accelerometer as /devices/virtual/input/input8
usb 2-3: new high-speed USB device number 3 using ehci-pci
psmouse serio1: synaptics: Touchpad model: 1, fw: 7.5, id: 0x1e0b1, caps: 0xd0  73/0x240000/0xa0400, board id: 1695, fw id: 739436
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/inpu
acpi-cpufreq: overriding BIOS provided _PSD data
mtrr: your BIOS has configured an incorrect mask, fixing it.
mtrr: your BIOS has configured an incorrect mask, fixing it.
mtrr: your BIOS has configured an incorrect mask, fixing it.
mtrr: your BIOS has configured an incorrect mask, fixing it.
mtrr: your BIOS has configured an incorrect mask, fixing it.
r8169 0000:01:00.0 eth0: unable to load firmware patch rtl_nic/rtl8105e-1.fw (  )
r8169 0000:01:00.0 eth0: link down

    [EDIT]: Added code tags.  Rich
« Last Edit: May 13, 2019, 08:49:23 AM by Rich »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: new to linux - No Wifi
« Reply #10 on: December 04, 2013, 03:04:02 PM »
From that dmesg log I do not see any WiFi devices installed, assuming it is not a USB device as you mentioned earlier.

now that you've mastered the copy an paste, how about doing the same with

lspci  (thats LSPCI)

and wrapping the pasted output in
Code: [Select]
might make things easier to read please

Offline potticous

  • WikiUser
  • *
  • Posts: 15
Re: new to linux - No Wifi
« Reply #11 on: December 04, 2013, 03:22:52 PM »
ok, but check my other thread here please: http://forum.tinycorelinux.net/index.php/topic,16326.0.html,
its a whole new question with new problems.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: new to linux - No Wifi
« Reply #12 on: December 04, 2013, 04:11:32 PM »
Not installing tinycore correctly to a USB stick may indeed cause many issues


BTW  to remedy this missing Ethernet device firmware, you may need to load this extension firmware-rtl_nic.tcz
r8169 0000:01:00.0 eth0: unable to load firmware patch rtl_nic/rtl8105e-1.fw (  )


Offline potticous

  • WikiUser
  • *
  • Posts: 15
Re: new to linux - No Wifi
« Reply #13 on: December 04, 2013, 06:02:05 PM »
Code: [Select]
tc@box:~$ lspci
sh: lspci: not found

 ???

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11368
Re: new to linux - No Wifi
« Reply #14 on: December 04, 2013, 07:23:14 PM »
is the pci-utils extension loaded?