WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: 5.x vlc and qt-4 --almost starts gui----starts in cli  (Read 8673 times)

gordonselfish

  • Guest
5.x vlc and qt-4 --almost starts gui----starts in cli
« on: September 14, 2013, 11:54:18 PM »
Hi

I have imported heaps of 4.x extensions that can roughly be seen in vlc loading command
Code: [Select]
tce-load -i vlc
libtasn1.tcz: OK
p11-kit.tcz: OK
gmp.tcz: OK
nettle.tcz: OK
gnutls2.tcz: OK
bzip2-lib.tcz: OK
taglib.tcz: OK
libavutil51.tcz: OK
libpostproc52.tcz: OK
libswscale2.tcz: OK
rtmpdump.tcz: OK
openjpeg.tcz: OK
faac.tcz: OK
lame.tcz: OK
x264-124.tcz: OK
liborc.tcz: OK
libogg.tcz: OK
libschroedinger.tcz: OK
speex.tcz: OK
libtheora.tcz: OK
libvorbis.tcz: OK
libvpx.tcz: OK
xvid.tcz: OK
libva.tcz: OK
libavcodec54.tcz: OK
libavformat54.tcz: OK
libproxy.tcz: OK
fribidi.tcz: OK
flac.tcz: OK
recode.tcz: OK
libiconv.tcz: OK
enca.tcz: OK
libass.tcz: OK
libdvdread.tcz: OK
libdvdnav.tcz: OK
qt-4.x-base.tcz: OK
libx11-xcb.tcz: OK
libxcb-util.tcz: OK
vlc.tcz: OK

2) in flwm_topside, starting vlc gives an additional error for Xinerama display issue
so I cheated and have Xorg-7.7 loading as well

3) I made 2 changes to 4.x dependencies as follows
vlc.tcz.dep
Change the dependency at the Xorg listing to show 7.7 but list itself left unchanged except the xorg issue
Quote
Xorg-7.7-lib.tcz
libxcb-util.tcz
libx11-xcb.tcz
qt-4.x-base.tcz
libiconv.tcz
libasound.tcz
libxml2.tcz
libvorbis.tcz
libtheora.tcz
libdvdnav.tcz
libass.tcz
flac.tcz
faac.tcz
fribidi.tcz
libproxy.tcz
libavformat54.tcz
libswscale2.tcz
libpostproc52.tcz
libgcrypt.tcz
taglib.tcz
bzip2-lib.tcz
gnutls2.tcz
shared-mime-info.tcz
hicolor-icon-theme.tcz

CHANGE 2
Change the dependency of qt-4.x-base.tcz.dep---same deal as vlc for xorg
Quote
Xorg-7.7-lib.tcz
fontconfig.tcz
glib2.tcz
openssl-1.0.0.tcz

#############
now try to run it......gui does not open
Code: [Select]
tc@box:~$ vlc
VLC media player 2.0.4 Twoflower (revision 2.0.3-289-g6e6100a)
[0x93ec0c8] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x93fe540] main interface error: option qt-volume-complete does not exist
[0x93fe540] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0x93fe540] skins2 interface error: cannot instantiate qt4 dialogs provider
Remote control interface initialized. Type `help' for help

I am hoping the only reason why it is not opening is due to qt-4-base might need a recompile?

What do you guys think?
« Last Edit: September 15, 2013, 12:09:14 AM by gordonselfish »

gordonselfish

  • Guest
Re: 5.x vlc and qt-4 --almost starts
« Reply #1 on: September 15, 2013, 12:08:44 AM »
so ignoring the gui error  I have sound thru cli

Code: [Select]
tce-load -i alsa (configure mixer)
mount /mnt/sda3
cd /mnt/sda3/g/SOUND

 tc@box:/mnt/sda3/g/SOUND$ cvlc percy.mp3
VLC media player 2.0.4 Twoflower (revision 2.0.3-289-g6e6100a)
[0x8764c70] dummy interface: using the dummy interface module...

 :)
 ;)
 ;D

Offline malbo

  • WikiUser
  • *
  • Posts: 22
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #2 on: April 29, 2014, 03:52:57 PM »
I have this same issue... The gui does not work. Any plans to update the qt extension for 5.x?

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #3 on: May 01, 2014, 12:12:47 AM »
Qt4 rebuilt for 5.x After some testing will add to repo as well as VLC which is running now.
« Last Edit: May 01, 2014, 12:58:07 AM by bmarkus »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #4 on: May 01, 2014, 06:57:13 AM »
vlc.tcz added to 5.x / x86 repo
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline malbo

  • WikiUser
  • *
  • Posts: 22
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #5 on: May 04, 2014, 01:15:41 PM »
Woo! Thank you, bmarkus!

Offline thane

  • Hero Member
  • *****
  • Posts: 657
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #6 on: May 15, 2014, 11:29:13 AM »
Belated thanks to bmarkus for vlc!

Thane

Offline abcdefg

  • WikiUser
  • *
  • Posts: 7
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #7 on: June 26, 2014, 05:14:02 AM »
vlc.tcz added to 5.x / x86 repo

Unfortunately, this extension does not work. The option to select the OSS audio output module is missing in the preferences dialogue. I cannot get sound with any other module, so the VLC extension is broken for me.

Furthermore, there is no Opus decoder. VLC supports the Opus audio format since at least version 2.0.4, but libopus has to be linked in. Libav required libopus for its Opus support and to my knowledge, a native Opus decoder has only been added recently to libav. Stable versions might not yet have the native decoder, meaning they require libopus when built in order to support the codec. Please build VLC with Opus support!

Finally, compared to the VLC extension from TinyCore 4.x, the TinyCore 5.x VLC extension is extremely bloated. Please compare http://tinycorelinux.net/4.x/x86/tcz/vlc.tcz.tree and http://tinycorelinux.net/5.x/x86/tcz/vlc.tcz.tree and leave out unnecessary garbage like gtk2 or librsvg or libpulseaudio and the like.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #8 on: June 26, 2014, 05:17:56 AM »
1) It does work. Your statement is not true.
2) What is not needed for you it may be needed by others.

Will check Opus. However you are free to build VLC for yourself configured as you like :)
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline abcdefg

  • WikiUser
  • *
  • Posts: 7
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #9 on: June 26, 2014, 05:37:12 AM »
1) It does work. Your statement is not true.
2) What is not needed for you it may be needed by others.

Will check Opus. However you are free to build VLC for yourself configured as you like :)

1) How were you able to select the OSS module? It is not shown in Tools > Preferences > Audio > Output module. I only see the following:

Automatic
Pulseaudio audio output
ALSA audio output
Audio memory output
File audio output
Dummy audio output
Disable

The VLC extension in TinyCore 4.x had OSS in the list. Is there another place where it can be selected now?

2) I would then still suggest to modularize it. Downloading the extra dependencies takes longer and increases traffic for everyone.

Thanks for checking Opus.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #10 on: June 26, 2014, 05:47:25 AM »
You can take over VLC maintenance and build a better extension for all of us. Just go ahead and submit the new version.

Why are you pushing OSS?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline abcdefg

  • WikiUser
  • *
  • Posts: 7
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #11 on: June 26, 2014, 07:47:06 AM »
Why are you pushing OSS?

I could have sworn ALSA didn't work for me in the past, but I'm on a fresh TinyCore 4.7.7 at the moment and just tested it again and to my surprise, I had sound. I have to test that later on the newer version, too. If that's the case, my main issue will be the lack of Opus support. Sorry for the noise then.

I wonder though why it is not possible to select the OSS module in the 5.x VLC extension. The nice thing about OSS is, that it is smaller. The version in the repo (build 2005) hasn't been updated in a while though. The current version (build 2009) has some fixes, according to its release notes. But if nobody here uses OSS, I guess there's no point in updating it.

I'll check later, if ALSA works for me in TinyCore 5.x, too, since I'm still puzzled why it just worked here at all. I might have accidentally used another computer in the past, where it didn't work.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #12 on: June 26, 2014, 08:19:44 AM »
I will check VLC build and OSS support. However I would prefer ALSA as it is the native Linux audio stack.

At the moment I'm not sure opus is handled by VLC or via FFMPEG libs, must check also.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7035
    • My Community Forum
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #13 on: June 26, 2014, 11:49:36 AM »
Rebuilt VLC. When OSS plugin enabled compilation fails, so it is disabled still. Now opus files played back. After few days testing will add to repo if everything goes well.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10314
Re: 5.x vlc and qt-4 --almost starts gui----starts in cli
« Reply #14 on: June 27, 2014, 12:42:53 AM »
The version in the repo (build 2005) hasn't been updated in a while though. The current version (build 2009) has some fixes, according to its release notes. But if nobody here uses OSS, I guess there's no point in updating it.

Basically all changes from 2005 to git were to the modules, which are from OSS git from 2014 Jan. The userspace apps being from release 2005 doesn't really matter if they haven't changed since then - the modules are up to date.
The only barriers that can stop you are the ones you create yourself.