General TC > General TC Talk

I broke my isolinux.cfg, and my google-fu is failing me [solved]

(1/1)

cg:
Hi all!  I'm trying to tell my remastered CDs to not use the boot menu.  My isolinux.cfg file looks like this:


--- Code: ---DEFAULT core

LABEL core
KERNEL /boot/vmlinuz
append initrd=/boot/core.gz quiet noutc host=Test_6d cde
--- End code ---

and the contents of /boot/isolinux are isolinux.bin (which I have not modified), and isolinux.cfg.  I deleted the bits that were mentioned in the original cfg file as relating to the menu, since they ought to be unnecessary.

The only changes I made to the filesystem were adding extensions and custom scripts that are caught by .filetool.lst - I didn't rename the kernel or anything like that.

S'anyway, when I burn and boot the disk, it goes fine until it tries to load the GUI, at which point I get a black screen with a black "x" mouse cursor.  If I hit ctrl-alt-del to escape the GUI, the CLI is responsive and works just fine.  Also, when I boot the same disk image without removing the menu items, it works fine.

Anyone know what's going on here?

tinypoodle:
1. Have you tried to run xsetup?
2. What happens if you add bootcode "norestore"?

cg:

--- Quote from: tinypoodle on August 10, 2012, 09:46:05 AM ---1. Have you tried to run xsetup?
2. What happens if you add bootcode "norestore"?

--- End quote ---

1. I have not.  Why would one do this, and what would it entail?

2. I will find out; it will take a few minutes for me to find out.  I'll post an update when I do.  Why am I trying this?  Doesn't norestore tell TC to not bother loading the backed-up files?

tinypoodle:
1. To see if X properly works after configuration.
2. To exclude that backup files play any role.

cg:
...I'm not sure what just happened, but I put the old disk (e.g. Test_6d) in the machine again, and it worked this time.

So!  Marking this as closed for the time being; I'll update if it starts doing it again.

Navigation

[0] Message Index

Go to full version