Tiny Core Extensions > TCE Talk

Graphics driver for Wyse C50LE terminal (VIA VX855)

(1/3) > >>

mbrijun:
Hello,

We are exploring an option of using Wyse C50LE terminals as Citrix workstations. These devices are based on VIA C7 CPU and feature the VX855 chipset.

I have been unable to get the X server to work. I have tried loading the "xf86-video-openchrome" extension, but the "sudo Xorg -configure" generates the following error:


--- Code: ---open /dev/fb0: No such device
Number of created screens does not match number of detected devices.
--- End code ---

Attached is the full Xorg.log

My "onboot.lst" looks like this:


--- Code: ---Xorg-7.6.tcz
Xprogs.tcz
Xorg-7.6-3d.tcz
xf86-video-openchrome.tcz
--- End code ---

I am reluctant to use VESA mode which I think would work. Please advise.

tinypoodle:

--- Quote from: mbrijun on July 31, 2012, 07:33:58 AM ---
--- Code: ---open /dev/fb0: No such device
Number of created screens does not match number of detected devices.
--- End code ---


I am reluctant to use VESA mode which I think would work. Please advise.

--- End quote ---

Last doesn't seem to make sense. Please rephrase.

From attached log it appears like support for 3 cards has been requested...

mbrijun:
Hi tinypoodle,

thanks for your reply. What I meant was that I would like to use Xorg-7.6 as opposed to Xvesa. I tried using Xvesa and it does work, although the resolution seems to be limited to 1024x768. I need support for 1280x1024 per monitor on dual screen machines.

Rich:
Hi mbrijun
I'm running Xorg7.5 on my machine because Xorg7.6 would not work with my hardware. Just a thought.

tinypoodle:

--- Quote from: mbrijun on August 01, 2012, 04:23:19 AM ---I tried using Xvesa and it does work, although the resolution seems to be limited to 1024x768.

--- End quote ---

Does that apply for both Xvesa.tcz and Xvesa-7.1.tcz or not?

Navigation

[0] Message Index

[#] Next page

Go to full version