WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] Apps browser can't connect  (Read 621 times)

nomer

  • Guest
[SOLVED] Apps browser can't connect
« on: July 04, 2012, 02:27:09 PM »
Hi there, I seem to be having problems connecting to the repository. When I run "apps" on the command line, click on Apps>Cloud(Remote)>Browse
 I get this error message
Quote
wget: server returned error: HTTP/1.1 404 Not Found
Also, it throws me the error window telling me to check network, server, and the extension directory.
I'm not using the mirrors extension.
Is the server down right now? What gives?
« Last Edit: July 05, 2012, 11:37:45 AM by nomer »

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Apps browser can't connect
« Reply #1 on: July 04, 2012, 06:40:05 PM »
Searching forum might potentially lead you to some hints how to troubleshoot this.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

nomer

  • Guest
Re: Apps browser can't connect
« Reply #2 on: July 05, 2012, 11:37:13 AM »
You're right. After searching around a while a found some help.

I'm not sure what caused the problem in the first place. Apps wasn't trowing any GUI errors, only command-line errors. In order to fix the problem I tried installing mirrors.tcz and I also tried manually editing /opt/tcemirror. Neither of those worked so I removed mirrors.tcz and rebooted. After reboot, I got the behavior described in the first post.

The cause of the final issue was that /opt/tcemirror looked like this:
Quote
<some url here>http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/
This obviously doesn't work.
I simply removed the first url and everything now works.

Cheers,
Nomer

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7904
Re: [SOLVED] Apps browser can't connect
« Reply #3 on: July 05, 2012, 02:00:31 PM »
Which version was this on? I recall one bug already fixed in Apps where the tcemirror file was corrupted like that.
The only barriers that can stop you are the ones you create yourself.

nomer

  • Guest
Re: [SOLVED] Apps browser can't connect
« Reply #4 on: July 06, 2012, 08:32:52 AM »
Oh, I'm sorry that I forgot to mention that. I'm running version 4.5.3