Tiny Core Base > TCB Q&A Forum

Minimizing TCE's disk space

(1/5) > >>

leekimpark:
So I'm fairly new to linux and tce, but I've been trying to install TCE and have it use the minimum amount of disk space. I've been testing it out on Virtualbox and I can't seem to bring down the disk usage to around 10mb. Right after installing using the Core-plus.iso to install with frugal install and options like text only, this is what my disk space usage looks like, using df -h

Filesystem   Size   Used   Available   Use%   Mounted on
rootfs      222.8M    9.4M   213.4M   4%   /
tmpfs      123.8M         0   123.8M   0%   /dev/shm
/dev/sda1       7.9G   25.6M       7.8G   0%   /mnt/sda1
/dev/sda1       7.9G   25.6M       7.8G   0%   /home
/dev/sda1       7.9G   25.6M       7.8G   0%   /opt

From what I've been reading via the website and google, TCE should be able to achieve much lower disk usage. I've also seen this thing about microcore, and I've tried to install it, but I can't seem to find the microcore.gz file during installation. All it gives me is core.gz. But regardless, what are other ways I can reduce disk space to about 10mb, or is this not possible? Sorry if this is a really newbie question.

Rich:
Hi leekimpark
The core.gz and vmlinuz files in your /mnt/sda1/boot/ directory account for about 12MB of that. To find out what
is taking the remaining space, check under the /mnt/sda1/tce/ directory.
Microcore is just called Core now and consists of core.gz and vmlinuz.

leekimpark:
Hi Rich,
There doesn't appear to be much in /mnt/sda1/tce, aside from the boot directory. Here's what ls -alh gives me:
total 20
drwxrwxr-x   5 tc   staff   4.0K Jun 28 05:20 ./
drwxrwxr-x   6 root   root   4.0K Jun 28 05:20 ../
drwxrwxr-x   3 tc   staff   4.0K Jun 28 05:20 boot/
-rw-rw-r--   1 tc   staff       0 Jun 28 05:20 mydata.tgz
-rw-rw-r--   1 tc   staff       0 Jun 28 05:20 onboot.lst
drwxrwxr-x   2 tc   staff   4.0K Jun 28 05:20 ondemand/
drwxrwxr-x   2 tc   staff   4.0K Jun 28 05:20 optional/
when I cd into and ls in the optional and ondemand directories there doesn't appear to be anything. Where else could the remaining space be used?

Rich:
Hi leekimpark
Try   du /mnt/sda1 | less
Use PageUp/PageDown to navigate, q to quit.

leekimpark:
Hi Rich,
du /mnt/sda1 gives me:

4.0K   /mnt/sda1/home/tc/.local/bin
8.0K   /mnt/sda1/home/tc/.local
24.0K   /mnt/sda1/home/tc
28.0K   /mnt/sda1/home
40.0K   /mnt/sda1/tce/boot/extlinux
7.6M   /mnt/sda1/tce/boot
4.0K   /mnt/sda1/tce/optional
4.0K   /mnt/sda1/tce/ondemand
7.6M   /mnt/sda1/tce
28.0K   /mnt/sda1/opt
16.0K   /mnt/sda1/lost+found
7.7M   /mnt/sda1

Still doesn't look like much, perhaps I messed up during the installation?

Navigation

[0] Message Index

[#] Next page

Go to full version