WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: chromium-browser.tcz default theme  (Read 1197 times)

nomer

  • Guest
chromium-browser.tcz default theme
« on: June 02, 2012, 02:34:32 PM »
Whooohooo!  :)
I'm now running a the latest version of Chromium. There seems to be a small problem however. The default theme is very horrible looking. Is it supposed to look like this or is there a problem with my system? It looks this way using a pre-existing Chromium profile and when using a brand new one.
I've attached images of the default theme.
I can work around this by installing a different theme, but it seems like it should ship with a decent looking one.
Thanks,
Nomer

EDIT: I'm running TinyCore 4.5.3
« Last Edit: June 04, 2012, 04:35:17 PM by nomer »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7903
Re: chromium-browser.tcz default theme
« Reply #1 on: June 03, 2012, 12:58:51 AM »
Corruption, eh? It could be either a bug or hardware beginning to fail.
The only barriers that can stop you are the ones you create yourself.

nomer

  • Guest
Re: chromium-browser.tcz default theme
« Reply #2 on: June 03, 2012, 04:32:02 AM »
I don't think that it is a problem with the hardware.
I have also found another workaround. All I had to do was change this:
Quote
/usr/local/bin/Xvesa -br -screen 1280x1024x24 -shadow -mouse /dev/input/mice,5 -nolisten tcp -ac -I >/dev/null 2>&1 &
to this
Quote
/usr/local/bin/Xvesa -br -screen 1280x1024x12 -shadow -mouse /dev/input/mice,5 -nolisten tcp -ac -I >/dev/null 2>&1 &
in ~/.xsession
and then the default theme displays just fine.
However, this makes some of the games I play angry.....

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7903
Re: chromium-browser.tcz default theme
« Reply #3 on: June 03, 2012, 05:23:39 AM »
12 bits is going to be a lot of banding, that's 4k colors only. Did you mean 32?

Could also try Xorg.
The only barriers that can stop you are the ones you create yourself.

nomer

  • Guest
Re: chromium-browser.tcz default theme
« Reply #4 on: June 03, 2012, 11:59:12 AM »
Nope, I meant 12. It also works with 16. The sad thing is that Chromium will only display the default correctly with a value less than 24, but Battle for Wesnoth will only display correctly with 24 or greater.

I suppose that I should probably try to get Xorg working. Getting the display correct has been a problem for quite a few distros on this computer, but Xvesa on TinyCore does a superb job.

(I've attached a screenshot ov the correct display.)

nomer

  • Guest
Re: chromium-browser.tcz default theme
« Reply #5 on: June 03, 2012, 02:01:23 PM »
Hey, I got Xorg running!   ;D
Now both Chromium and Battle for Wesnoth display correctly.

I would just like to mention one thing. At one point when I started chromium-browser on the command-line while running Xorg chromium spit out this:
Quote
The program 'exe' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadPixmap (invalid Pixmap parameter)'.
  (Details: serial 127 error_code 4 request_code 54 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Perhaps this helps explain the problem and perhaps the package maintainer(Arslan S.) should send it upstream.

Thanks for all your help,
Nomer

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7903
Re: chromium-browser.tcz default theme
« Reply #6 on: June 04, 2012, 01:20:26 AM »
Please report any bugs yourself, it may not be that Arslan can reproduce them. Also, please report both bugs (corruption in Xvesa, BadPixmap with Xorg).
The only barriers that can stop you are the ones you create yourself.

Offline Arslan S.

  • Hero Member
  • *****
  • Posts: 825
Re: chromium-browser.tcz default theme
« Reply #7 on: June 04, 2012, 03:16:48 AM »
i can reproduce this problem (with xvesa), just use another theme i.e. gtk-theme is not bad or download one from google store

nomer

  • Guest
Re: chromium-browser.tcz default theme
« Reply #8 on: June 04, 2012, 04:32:25 PM »
@curaga
  Okay, I'll try to do that.
@Arslan S.
  Yes, but I really like the default theme and you can't get the default theme from the Google Store.
  Perhaps you could make a note of this issue in the .info file. (I must admit, the file already is reasonably large and you do mention how to get new themes.)
@all
Cheers,
Nomer