Tiny Core Base > TCB Q&A Forum

javac doesn't work [SOLVED, kinda]

(1/1)

nomer:
I want to be able to compile a program written in java. Unfortunately, I just discovered that my compiler isn't working.
I'm using sun-jdk.tcz from the repository.
When I run "javac" with or without arguments at the commandline, I get this response:

--- Quote ---javac: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory
--- End quote ---
sun-jdk.tcz is in onboot.lst

--- Quote ---echo $JAVA_HOME
/usr/local/java-sun/

--- End quote ---

--- Quote ---echo $J2SDKDIR
/usr/local/java-sun
--- End quote ---

--- Quote ---find /usr | grep libjli.so
/usr/local/java-sun/jre/lib/i386/jli/libjli.so
--- End quote ---
Does anyone else have sun's jdk working on tinyCore 4.4 ?

P.S. I would use openjdk but libreoffice.tcz currently depends on sun-jre.tcz and I don't feel like having two jre's on my system.

nomer:
I believe that I've solved my problem simply by installing openjdk-7-jdk.tcz
Now both the openjdk7 versions of "java" and "javac" are higher in the path than their sun-jdk counterparts.
chromium-browser is still using the sun-jre plugin and LibreOffice seems to be working fine.
This is all fine with me.

vinnie:
Today i try sun-jdk7:

make file named myfirstjavaprog.java

--- Code: ---class myfirstjavaprog
{
public static void main(String args[])
{
System.out.println("Hello World!");
}
}
--- End code ---

exec javac myfirstjavaprog.java
exec java myfirstjavaprog.java


--- Code: ---tc@box:~/java$ java myfirstjavaprog     
Hello World!

--- End code ---

In my case jdk works

Navigation

[0] Message Index

Go to full version