Tiny Core Extensions > TCE Q&A Forum

How to display Chinese (Unicode) in urxvt.

<< < (2/2)

solorin:
So I managed to install the terminfo entry into ~/.terminfo/ by executing tic (from ncursesw-utils.tcz) on the terminfo file provided in the upstream sources.

then,
tce-load -i locale-col-zh.tcz
tce-load -i urxvt-daemon.tcz
tce-load -i xfonts-ffs.tcz (puts bitmap fireflysung fonts into /usr/share/fonts/firefly)
xset +fp /usr/share/fonts/firefly
xset fp rehash
urxvtd -q -o -f
urxvtc -fn firefly16 -tr +sb -vb -fg white

move to the newly spawned terminal.
export LANG='zh_TW.utf8'
w3m test.zh.utf-8

but it's still an unreadable mess.

I feel like I'm groping around in the dark for a small missing piece.
There must be other tinycore users who can display international characters in
urxvt. Would somebody be so kind to enlighten me?

Thanks,
solorin

solorin:
Ok. I'm pretty sure it's unicode/multi-byte support in various programs.

I managed to configure w3m some more and finally got some results. It displays chinese characters. However, they are not intelligible, and despite my chinese being rudimentary at best, AFAICT it's still not displaying the correct text. I think I might I have to recompile w3m or dig through some more w3m documentation (oh joy).

I was disappointed to find that vim was compiled without multi-byte support. But from packaging other extensions I know that given a long list of compile options, you try and prune them for a compact useful extension. (Vim also has a ton of options. Even thinking about rebuilding a private extension makes me shudder.) Unicode support and the like are likely some of the first things to go, as stock Core doesn't have good support for it anyway.

But if you do make an extension with unicode support and you don't already do it, can I ask extension packagers to add 'unicode' into their list of tags when they next update? That would help users looking for support find it quickly and conveniently.

Thanks all.

cheerio,
solorin

solorin:
http://www.cl.cam.ac.uk/~mgk25/unicode.html

ok, silly me. it sez here, cat and echo work on streams, so unicode should display fine.
and also that less should be unicode aware out of the box.
I tried with busybox cat and coreutils cat
no go.
and also with the busybox less, and the full version.
nada. zilch.

i really don't understand why this isn't working.

i'm also really skeptical that there isn't at least one other tinycore user
who's been able to get  this working or wants to get this working.

am i posting in the wrong language? I feel like I'm taking crazy pills here.

cheerio,
solorin

Navigation

[0] Message Index

[*] Previous page

Go to full version