WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Problems running a mix of 32-bit & 64-bit binaries on microcore64 version 3.8.4  (Read 1117 times)

Offline hookenz

  • Newbie
  • *
  • Posts: 8
Hello tinycore community.

I'm wondering if anyone has had the types of issues I'm currently facing when mixing 64bit apps & shared libraries on the any of the 64bit
releases of tinycore64 or microcore64 since the userland tools like busybox are actually 32-bit ones.

What I did was simply create the directories /lib64 & /usr/lib64 in my remastered microcore64.
I then appended those paths to /etc/ld.so.conf and ran ldconfig with the correct path.
The cache file appears to have picked up the libraries correctly.

However, when running an app that uses libraries from the lib64 directories I get a string of these errors:

"error while loading shared libraries: lib...so.1 cannot open shared object file: no such file or directory."

The files are definitely there in /usr/lib64

File permissions are 0755 with root user & group ownership on them.

Running the file command on any of the troublesome 64bit binaries prints a "wrong elf class: ELFCLASS64" error.

I have successfully gotten the a 64-bit bridge utils (brctl) to run which depends on a couple of shared libraries in /lib64 and that works.

Am I going about this correctly, or do I actually need to do a little more than just put these files in the 64bit libpath and update the ld.conf.cache. 
Also, why is the file command producing the elf class error? is it because busybox is the 32bit version?
Should I upgrade busybox to a 64 version?

Thanks in advance.
« Last Edit: April 04, 2012, 08:52:08 PM by hookenz »

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3425
You will need to ask the builder of those 64bit binaries, as Core has included no support for 64bit user space.