Tiny Core Base > Micro Core

microcore64 is not 64bit?

(1/2) > >>

hookenz:
I'm wanting to remaster an older microcore64 3.8.4 with a custom kernel build from the 2.6.32.x series.
I got it to run up ok, but when I put some 64bit binaries onto it I ran into some problems.

When I ran file /bin/busybox it shows up as ELF 32-bit.  As do all the files on the system.
To ensure it wasn't just a problem with that build I had a look at an earlier version & the very latest 4.4 core64.gz.
These have the same issue.  All the binaries and files on it are in fact 32bit elf.

Is this expected or known?

hookenz:
I guess it's not a huge problem that busybox and the other files are 32bit.  I just need to put all the 64bit binaries & libraries into lib64 and I should be away right?

Provided that I'm running a 64bit kernel.

I do wonder what the difference is between core and core64 if they both have 32bit binaries for what looks like everything as far as I can tell.

gerald_clark:
There are no 64 bit binaries or libraries.
User space is 32 bit.

curaga:
The difference is the 64-bit kernel. Using it you can access all RAM and get some of the 64-bit speed advantages.

hookenz:
Thanks, I actually forgot in /lib/modules are the kernel modules which in the core64 version will be 64bit.

However, userspace is running 32bit shell etc.  This doesn't stop me running 64bit apps.

Navigation

[0] Message Index

[#] Next page

Go to full version