WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: (solved) Issues with a PC with NVDIA GForce FX5200 (NV34); which Xorg.conf ?  (Read 7041 times)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4194
Hi floppy
It's possible the nvidia driver is buggy. Maybe you want to try the driver that comes with Xorg.
In the  Device  section of your  xorg.conf  change:
Code: [Select]
    Driver         "nvidia"to:
Code: [Select]
    Driver         "nv"and see how that behaves.

Offline floppy

  • Hero Member
  • *****
  • Posts: 577
Extension name?
AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4194
Hi floppy
It's part of the  Xorg7.5 extension (/usr/local/lib/X11/modules/drivers/nv_drv.so). Changing  nvidia  to  nv  in your
existing  xorg.conf  file should be sufficient to try it out.

Offline floppy

  • Hero Member
  • *****
  • Posts: 577
1) I wanted to give a try to "NvAGP"  "1" and blacklist AGPGART + SIS_AGP (nvidia driver + Xorg7.5) = use of the nvidia AGP.
Result (sort of improvement)
   The screen comes.
   Wbar is there.
-> PC preeze after few mouse movement

2) Xorg7.6 dont start due to glx failed to load. I will load nvidia-glx at boot and post any result here.

I will try rich recommendation a bit later (exchange nvidia with nv driver).
« Last Edit: April 11, 2012, 10:49:50 AM by floppy »
AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline floppy

  • Hero Member
  • *****
  • Posts: 577
Solved. The nv driver from xorg75 had to be used (not the last nvidia driver after compilation).

- asrock Motherboard K7S8X
- Nvidia FX 5200 PCI  10de:0322,  SiS chipset [1039/0746]
- Core 4.4 (kernel 3.0.21)

====================== extlinux command =================
LABEL core4.4
   MENU LABEL core4.4
   KERNEL /boot/core4_4/vmlinuz
        APPEND vga=ask quiet showapps pause waitusb=5:UUID="cc9e97b9-67de-4e85-8f80-750a7d0f8841" tce=UUID="cc9e97b9-67de-4e85-8f80-750a7d0f8841"/tce4 lst=asrockxorg.lst mydata=fx5200
        initrd /boot/core4_4/core.gz

====================== xorg.conf ========================
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Sun Jul 17 22:46:17 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "de"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 96.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nv"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Virtual     1024 768
        Depth       24
        Modes      "1024x768"
    EndSubSection
EndSection


====================== onboot.lst ========================
fltk-1.10.tcz
Xlibs.tcz
appbrowser-cli.tcz
wbar.tcz
Xprogs.tcz
flwm_topside.tcz
Xorg-7.5.tcz

====================== .filetool.lst ========================
opt
etc/X11/xorg.conf

====================== lsmod result ======================
Module                  Size  Used by    Tainted: P 
cpufreq_userspace      12288  0
cpufreq_powersave      12288  0
cpufreq_stats          12288  0
cpufreq_conservative    12288  0
squashfs               24576 30
scsi_wait_scan         12288  0
zcache                 12288  0
zram                   12288  1
loop                   16384 60
ppdev                  12288  0
pcspkr                 12288  0
sis900                 20480  0
parport_pc             24576  0
floppy                 45056  0
parport                24576  2 ppdev,parport_pc

=======================================================
Im writing fom the pc with the nvidia card.

THANKS RICH.
« Last Edit: April 11, 2012, 01:02:28 PM by floppy »
AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4194
Hi floppy
It's too bad the driver you compiled did not work, but least the built-in driver sounds like it is working for you.
You also no longer require   Option     "NvAGP" "1"

Offline floppy

  • Hero Member
  • *****
  • Posts: 577
yes. If somebody need the nvidia-173.14.31-3.0.21-tinycore.tcz , I can submit it.
Perhaps not necessary: Rich compilation script earlier in the thread is fine.
Perhaps should I contact nvidia to inform them of the "non success" so, they can improve the driver again. Who? Where to contact them?
« Last Edit: April 11, 2012, 01:28:25 PM by floppy »
AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline floppy

  • Hero Member
  • *****
  • Posts: 577

2. I used Xorg7.5. Xorg7.6 would freeze up on me.

Update 1: I achieved to boot that nvidia FX5200 with knoppix 6.7.1 (Xorg7.6) with the "nouveau" driver (no Xorg.conf) by disabling the acceleration with a knoppix cheat code "nouveau.noaccel=1".

So, a guess with TCL and nvidiaFX5200 would be (probably)
- load Xorg 7.6 at boot
- create an Xorg.conf which disable the acceleration..
- AND wait for a new "nouveau" driver supporting the accelation for the FX5200
- AND (better).. simply stay with Xorg7.5 as posted before

Update 2: the first errors at the beginning of that thread came probably because the CD Reader and the CD/DVD Writer were both on the master IDE cable and the MoBo had issues loading data. According the asrock BIOS update info, a BIOS upgrade would solve the issue. In fact, now, I have moved the CD and CD/DVD on the slave IDE cable, putted the newest BIOS on the PC, connected the HDD to the master IDE cable. And: the whole system is running stable since few weeks.

AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7774
It's likely nouveau will never support your 5200 properly. They only have a few people and focus on the new cards.
The only barriers that can stop you are the ones you create yourself.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3836
Update 1: I achieved to boot that nvidia FX5200 with knoppix 6.7.1 (Xorg7.6) with the "nouveau" driver (no Xorg.conf) by disabling the acceleration with a knoppix cheat code "nouveau.noaccel=1".

Have you tried the same with TC?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7774
We don't have nouveau in the repo at all, as it wasn't stable at the time of the builds.
The only barriers that can stop you are the ones you create yourself.

Offline floppy

  • Hero Member
  • *****
  • Posts: 577
We don't have nouveau in the repo at all, as it wasn't stable at the time of the builds.
Since TinyCore with the "nv" driver stop working for my fx5200 card after few time (depend of the activity with the PC: from 15min to 1/2h), I would like to make a "nouveautesting" extension.
Has somebody any advice how to create that extension?
Perhaps it is the same procedure as for creating an nvidia extension indicated in the beginning of that thread?
« Last Edit: August 26, 2012, 11:06:54 AM by floppy »
AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline Gawron

  • Newbie
  • *
  • Posts: 11
Hi floppy xorg-7.6 works without troubles with GeForce FX 5200. The problem is probably in your hardware. On my computer I only added nv diver to my system with command
tce-load -wi xf86-video-nv
My xorg.conf has driver nv in section device. So far had no problems with this driver. Only changed resolution for my screen in section monitor.
Here is my xorg.conf
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "pl"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
EndSection

Section "ServerFlags"
    Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection
Section "Files"
    FontPath     "/tmp/tcloop/xfonts-unifont/usr/lib/X11/fonts/misc/"
EndSection

Section "Module"
    Disable "dri"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "glx" # 3D layer
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "SyncMaster"
    HorizSync 30-81
    VertRefresh 56-75
   
    # Monitor preferred modeline (59.9 Hz vsync, 55.9 kHz hsync, ratio 16/10, 89 dpi)
    ModeLine "1440x900" 106.5 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
   
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
   
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce FX series"
    Driver "nv"
    Option "DPMS"
    Option "DynamicTwinView" "false"
    Option "AddARGBGLXVisuals"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection
« Last Edit: July 14, 2013, 12:06:47 PM by Gawron »