WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Audio on chrome browser  (Read 1433 times)

Offline newbie000

  • Newbie
  • *
  • Posts: 21
Audio on chrome browser
« on: April 02, 2012, 06:04:40 AM »
Hi all,

Currently i use tinycore 4.4 with google chrome browser addition (v15), but when i browse to video websites (i.e. youtube), no audio output (the video is working fine).

As far as i know all the dependencies are being downloaded/installed automatically during browser installation either via scm or app browser..

Is there any other package/library/plugin to enable the audio?

Thanks a lot!

Online bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 5026
    • My Community Forum
Re: Audio on chrome browser
« Reply #1 on: April 02, 2012, 06:08:42 AM »
Is sound subsystem (ALSA) installed, configured and works independently Chrome?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline newbie000

  • Newbie
  • *
  • Posts: 21
Re: Audio on chrome browser
« Reply #2 on: April 02, 2012, 06:51:11 AM »
Hi there,
Not yet, i will try to install alsa.tcz and will get back soon...

Thanks !

Offline newbie000

  • Newbie
  • *
  • Posts: 21
Re: Audio on chrome browser
« Reply #3 on: April 02, 2012, 08:55:48 PM »
Hi all,

Has installed alsa.tcz and its dependencies...still no audio  :(

Any suggestion ?

Thanks

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4244
Re: Audio on chrome browser
« Reply #4 on: April 02, 2012, 09:05:26 PM »
Hi newbie000
Did you read and follow the instructions in the  Info  tab in AppBrowser?

Offline newbie000

  • Newbie
  • *
  • Posts: 21
Re: Audio on chrome browser
« Reply #5 on: April 03, 2012, 01:40:44 AM »
Hi Rich,

I haven't done the persistent setup. I just run the script alsasound start and speaker-test as well.

Here is the output of speaker test:

speaker-test 1.0.24.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
 0 - Front Left
 1 - Front Right
Time per period = 2.855991


And the output of alsasound start:
rmmod: can't unload 'snd_hda_codec_realtek': Resource temporary unavailable
rmmod: can't unload 'snd_hda_codec': Resource temporary unavailable
rmmod: can't unload 'snd_hwdep': Resource temporary unavailable
rmmod: can't unload 'snd_pcm': Resource temporary unavailable
rmmod: can't unload 'snd_timer': Resource temporary unavailable
rmmod: can't unload 'snd': Resource temporary unavailable
Starting sound driver: snd-hda-intel

Is that normal or did i miss something here?

Thanks.

nomer

  • Guest
Re: Audio on chrome browser
« Reply #6 on: April 03, 2012, 05:18:49 AM »
@ newbie000
What do you hear when you run the speaker-test program?
On my machine I hear a hissing sound through the speakers, the loudness of which I can adjust by adjusting the master volume.

P.S. When you say that you're using "google chrome browser" I assume that you mean you're using chromium-browser.tcz
       This is actually "chromium" not "google chrome". There is a difference. (I think.)  ;)

Offline newbie000

  • Newbie
  • *
  • Posts: 21
Re: Audio on chrome browser
« Reply #7 on: April 03, 2012, 06:33:02 AM »
Hi Nomer,

I didn't hear a thing. What command to open the master volume ? I didn't find it on wbar or menu...do i need to install additional package?

Yup, i use chromium browser, not google chrome.

Thanks.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3418
Re: Audio on chrome browser
« Reply #8 on: April 03, 2012, 06:34:22 AM »
alsamixer

Offline mocore

  • Full Member
  • ***
  • Posts: 104
Re: Audio on chrome browser
« Reply #9 on: April 03, 2012, 12:18:52 PM »
alsamixer

i had some similar problem once with integrated audio chip on a laptop
 i had to change output setting on alsamixer
 and then i had sound !!

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3418
Re: Audio on chrome browser
« Reply #10 on: April 03, 2012, 01:14:22 PM »
Make sure you run "/usr/local/etc/init.d/alsasound start" first.

Offline newbie000

  • Newbie
  • *
  • Posts: 21
Re: Audio on chrome browser
« Reply #11 on: April 03, 2012, 06:26:54 PM »
Thanks all,

After using mixer gui i can see the volume bar is definitely set to zero then i maximized the master and front button, then its out!

The thing is the Front panel again set to 0 after restart...how to make the front panel set to maximize permanently?

Thanks all..


Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4244
Re: Audio on chrome browser
« Reply #12 on: April 03, 2012, 06:45:46 PM »

Offline newbie000

  • Newbie
  • *
  • Posts: 21
Re: Audio on chrome browser
« Reply #13 on: April 03, 2012, 07:10:09 PM »
Thanks Rick,

The link doesn't direct to any thread somehow...i insert alsasound start on .xsession as per recommended previously now the front panel bar is maximized after startup...

My other problem is the missing flash plugin on chromium browser so not all video can be played. Has installed getFlash11.tcz, but still no luck, will open a new thread for this.

Thanks alot!