WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: on 4.5rc java breaks on Vortex86mx  (Read 648 times)

Offline risto3

  • Newbie
  • *
  • Posts: 21
on 4.5rc java breaks on Vortex86mx
« on: April 21, 2012, 01:55:43 PM »
quite happy so far with TC 4.5 rc, thanks for tigervnc by the way.
but after trying to install libreoffice, message running said java not installed. funny, saw it in the install log.  tried running /usr/local/java-sun/jre/bin/java -version
no luck, here's the log attached.  help?


Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7911
Re: on 4.5rc java breaks on Vortex86mx
« Reply #1 on: April 21, 2012, 09:46:41 PM »
You're using Sun's binaries, which we have no control over. You can't even complain to Oracle, as they no longer let distros package the latest Java.

Since Sun had dropped old cpu support, you could try the open* java builds.
The only barriers that can stop you are the ones you create yourself.

Offline risto3

  • Newbie
  • *
  • Posts: 21
Re: on 4.5rc java breaks on Vortex86mx
« Reply #2 on: April 21, 2012, 10:07:11 PM »
In the application installer, I only chose libreoffice-fr.tcz
checking in its dependencies I see effectively sun-jre.tcz
seems like the dependency list should therefore be updated.

trying to install openjdk-6-jre.tcz now... will see how it works.
thanks

[update] seems to work fine now, great!  can't uninstall sun-jre, though, because it remains a dependency for libreoffice-fr.tcz and libreoffice.tcz.
===========

You're using Sun's binaries, which we have no control over. You can't even complain to Oracle, as they no longer let distros package the latest Java.

Since Sun had dropped old cpu support, you could try the open* java builds.
« Last Edit: April 21, 2012, 10:32:12 PM by risto3 »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4248
Re: on 4.5rc java breaks on Vortex86mx
« Reply #3 on: April 22, 2012, 04:58:14 AM »
Hi risto3
Quote
can't uninstall sun-jre, though, because it remains a dependency for libreoffice-fr.tcz and libreoffice.tcz.
If the dependency is due to  sun-jre.tcz  being listed in the dependency files, and not because libreoffice still relies
on any of the files in  sun-jre.tcz, you can remove it as follows:
1. Rename the libreoffice* files to mylibreoffice*. This is so a check for updates will not try to revert the extensions back.
2. Make the same changes in the two dependency files.
3. Replace  sun-jre.tcz  with  openjdk-6-jre.tcz  in the two dependency files.
That should allow you to uninstall  sun-jre.tcz. You will probably also need to unpack the two libreoffice extensions
and rename the  usr/local/tce.installed/libreoffice  files to  usr/local/tce.installed/mylibreoffice  and then repack them.

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: on 4.5rc java breaks on Vortex86mx
« Reply #4 on: April 23, 2012, 06:01:36 AM »
I have similar problem:
libreoffice do not work with sun-jdk7 and sun-jre.tcz do not work with sun-jdk7
The only way to use it is dropping sun-jdk7 in favour of sun-jre.
:/
If there is no solution I will try to download the scm, seems the best way

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: on 4.5rc java breaks on Vortex86mx
« Reply #5 on: April 30, 2012, 02:42:00 PM »
With the scm libreoffice version I can continue to safely use the version of Java 7.