WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TinyCore not detecting my Hard Drive  (Read 2084 times)

Offline lberezinski

  • Newbie
  • *
  • Posts: 2
TinyCore not detecting my Hard Drive
« on: March 23, 2012, 06:16:58 AM »
I'm fairly new to Linux and i'm trying to install tiny-core on my webdt 366.
but it seems not to detect the webdt internal flash drive.

i was able to boot with gparted live CD and see & format my disk my disk.
i was also able to boot with Ubuntu and see my disk.

any ideas?

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: TinyCore not detecting my Hard Drive
« Reply #1 on: March 23, 2012, 07:01:25 AM »
from which media tinycore is booted?
possible need add waitusb bootcode?
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline lberezinski

  • Newbie
  • *
  • Posts: 2
Re: TinyCore not detecting my Hard Drive
« Reply #2 on: March 23, 2012, 07:11:41 AM »
I'm booting from a USB cd-rom (CorePlus-4.4.iso)

so just to clarify

i have a webdt 366 (with one USB port)
a USB keyboard with two USB ports is connected to the webdt USB port
a USB mouse is connected to the first USB port on the keyboard
a USB cd-rom (booting device) is connected o the second USB port on the keyboard

i have tried the waitusb option but i still could not see my drive

when i use gparted it is mounted as hda1 and when i used Ubuntu it is mounted as sda1

Offline gutmensch

  • Administrator
  • Hero Member
  • *****
  • Posts: 606
  • I can make it disappear, have no fear!
    • remembrance blog
Re: TinyCore not detecting my Hard Drive
« Reply #3 on: March 23, 2012, 07:26:39 AM »
It's possible the built-in Flash ROM NAND chip is not initially supported, from some info in the web I found out that it might be a classic Geode Companion chip, possibly supported by the kernel options

Code: [Select]
CONFIG_MTD_NAND_CS553X

which we only include as a module, but I'm not sure it's present. Maybe curaga can help out here...

Source: http://webdt.org/forum/viewtopic.php?t=100
If I seem unduly clear to you, you must have misunderstood what I said. (Alan Greenspan)

Offline AbNoRMiS

  • Hero Member
  • *****
  • Posts: 551
  • nothing can be impeccable in this imperfect world
    • @ß№®M!$
Re: TinyCore not detecting my Hard Drive
« Reply #4 on: March 23, 2012, 08:58:55 AM »
if it's so i think that need download mtd-3.0.21-tinycore.tcz
and load module cs553x_nand
Code: [Select]
tce-load -wil mtd-3.0.21-tinycore.tcz
modprobe cs553x_nand
it is right?
Basic Design Concept © @ß№®M!$
please forgive my terrible english :)

Offline gutmensch

  • Administrator
  • Hero Member
  • *****
  • Posts: 606
  • I can make it disappear, have no fear!
    • remembrance blog
Re: TinyCore not detecting my Hard Drive
« Reply #5 on: March 23, 2012, 09:08:25 AM »
absolutely right, nice find... I didn't remember the mtd extension :-o
but however, a remaster would be needed to run at boot time, because of the chicken egg... loading an extension for the drive from which you're loading the extension for the... ;-)
If I seem unduly clear to you, you must have misunderstood what I said. (Alan Greenspan)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7611
Re: TinyCore not detecting my Hard Drive
« Reply #6 on: March 23, 2012, 11:43:58 PM »
I'm not sure whether it's accessed via MTD or IDE. Check your dmesg from either gparted or ubuntu.

If via IDE, it's possible it has the cs5535 chip, which is still experimental in libata and thus disabled in our build.
The only barriers that can stop you are the ones you create yourself.

Offline nekys

  • Newbie
  • *
  • Posts: 4
Re: TinyCore not detecting my Hard Drive
« Reply #7 on: May 22, 2012, 05:19:04 PM »
I have same problem, I tried:
tce-load -wil mtd-3.0.21-tinycore.tcz
modprobe cs553x_nand
and I get this:
modprobe: can't load module cs553x_nand (kernel. tclocal/ drivers/ mtd/ nand/ cs553x_nand. ko. gz): No such device or address

Where I think I have to do something with depmod...

Offline nekys

  • Newbie
  • *
  • Posts: 4
Re: TinyCore not detecting my Hard Drive
« Reply #8 on: May 22, 2012, 05:41:21 PM »
I found that mtd from repository has path for the modules as /usr/local/lib/modules and not /lib/modules. I moved the modules inside /lib/modules and still doesn't work.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6128
Re: TinyCore not detecting my Hard Drive
« Reply #9 on: May 22, 2012, 07:16:15 PM »
I found that mtd from repository has path for the modules as /usr/local/lib/modules and not /lib/modules
/usr/local/lib/modules is the standard tinycore location for modules in an extension

Quote
Where I think I have to do something with depmod
tce-load performs this automatically

Perhaps the module is not recognising your hardware, does "modinfo cs553x_nand" show any optional parameters you could pass?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4119
Re: TinyCore not detecting my Hard Drive
« Reply #10 on: May 22, 2012, 08:30:38 PM »
modinfo shows:
Quote
filename:       kernel.tclocal/drivers/mtd/nand/cs553x_nand.ko.gz
description:    NAND controller driver for AMD CS5535/CS5536 companion chip
author:         David Woodhouse <dwmw2@infradead.org>
license:        GPL
vermagic:       3.0.3-tinycore SMP mod_unload 486
depends:        mtd,nand,nand_ecc

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6128
Re: TinyCore not detecting my Hard Drive
« Reply #11 on: May 22, 2012, 09:35:11 PM »
There's a problem if modinfo shows "3.0.3-tinycore SMP mod_unload 486" and the extension is named "mtd-3.0.21-tinycore.tcz"...

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7611
Re: TinyCore not detecting my Hard Drive
« Reply #12 on: May 23, 2012, 03:37:00 AM »
The error " No such device or address" is clear, the module loaded successfully but you have no such hardware. Or the module does not support your hw.
The only barriers that can stop you are the ones you create yourself.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4119
Re: TinyCore not detecting my Hard Drive
« Reply #13 on: May 23, 2012, 04:48:39 AM »
Hi Juanito
My apologies, I should have stated that I performed that command under TC4.1 (3.0.3).

Offline nekys

  • Newbie
  • *
  • Posts: 4
Re: TinyCore not detecting my Hard Drive
« Reply #14 on: May 23, 2012, 11:45:02 AM »
The error " No such device or address" is clear, the module loaded successfully but you have no such hardware. Or the module does not support your hw.

For sure I have that hardware since I opened my device and this is what the chip writes on it.