WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: LIRC w/ audio_alsa  (Read 1757 times)

Offline mb0

  • Jr. Member
  • **
  • Posts: 86
LIRC w/ audio_alsa
« on: March 22, 2012, 03:39:42 PM »
I am attempting to use an IR module with lirc via the audio input.

However, if i run;

Code: [Select]
lircd --driver=audio_alsa -d hw@48000it returns
Code: [Select]
Driver `audio_alsa' not supported.and lists a bunch that are.

Any suggestions on where i go from here???
« Last Edit: March 22, 2012, 03:41:26 PM by mb0 »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4193
Re: LIRC w/ audio_alsa
« Reply #1 on: March 22, 2012, 04:53:21 PM »
Hi mb0
Are you connecting the digital output of an IR module to an analog (mic, line, etc.) input on your computer?
That won't work.
Quote
and lists a bunch that are.
If "bunch" includes parallel or serial, you might want to try one of those.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 180
    • AmatCoder Projects
Re: LIRC w/ audio_alsa
« Reply #2 on: March 23, 2012, 12:04:32 AM »
I am attempting to use an IR module with lirc via the audio input.
[...]

LIRC was compiled without 'audio' drivers support ('audio' and 'audio_alsa'). You need compile your own.

Are you connecting the digital output of an IR module to an analog (mic, line, etc.) input on your computer?
That won't work.
[...]
They claim to can do it so... http://www.lirc.org/html/audio-alsa.html

Offline mb0

  • Jr. Member
  • **
  • Posts: 86
Re: LIRC w/ audio_alsa
« Reply #3 on: March 23, 2012, 04:44:54 AM »
Parallel and serial were not in that list, no.

AmatCoder; i see.. you were helping me before (when i was trying to use my IRDA port), and offered

Quote
I can post here my  'step-by-step to compile lirc 0.9.0'
.. that would be much appreciated right now if the offer still stands?  :)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4193
Re: LIRC w/ audio_alsa
« Reply #4 on: March 23, 2012, 07:17:59 AM »
Hi AmatCoder
Yes, if you limit the voltage using a diode as shown in that link, it should be OK. If you don't, you might see zero
when you are putting in a one.


Offline mb0

  • Jr. Member
  • **
  • Posts: 86
Re: LIRC w/ audio_alsa
« Reply #5 on: March 24, 2012, 07:46:46 AM »
well.. i've been having a go since AC hasn't been around.. according to the instructions at http://www.lirc.org/git.html

i have git/libtool/automake/autoconfig installed from ab. when i do as suggested;
Code: [Select]
cd /tmp
git clone git://lirc.git.sourceforge.net/gitroot/lirc/lirc
cd lirc
./autogen.sh
./setup.sh
make
autogen script returns a few 'not found' errors, although it says to ignore that on the lirc site. So carrying on.. setup.sh doesn't have the options i would have expected? (ie no option to change driver, irq, etc). Selecting save and run configure.. seems to do nothing. Then running make, it complains 'No targets specified and no makefile found.'.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6327
Re: LIRC w/ audio_alsa
« Reply #6 on: March 24, 2012, 07:50:35 AM »
You could try loading libtool-dev, glib2-dev, gettext and intltool and then running ./autogen.sh from the clean source

Offline mb0

  • Jr. Member
  • **
  • Posts: 86
Re: LIRC w/ audio_alsa
« Reply #7 on: March 24, 2012, 09:30:01 AM »
Thanks.. pretty sure that improved things somewhat.. but still not there. running make still returns 'no targets...'

after running setup.sh it returned
Code: [Select]
checking for linux/i2c-dev.h... yes
configure: error: *** you need to have the Linux kernel source installed
        for this driver'
without saying what driver it was referring to (or ever giving me any options of which ones i wanted to install). I really hope i don't need to get the whole linux kernel source just to build this.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6327
Re: LIRC w/ audio_alsa
« Reply #8 on: March 24, 2012, 09:38:17 AM »
You can probably get away with using the linux-headers-3.0.21-tinycore extension

Offline mb0

  • Jr. Member
  • **
  • Posts: 86
Re: LIRC w/ audio_alsa
« Reply #9 on: March 24, 2012, 10:15:55 AM »
Right, that seemed to work, awesome, thanks. So.. then I created the .tcz with
Code: [Select]
cd /tmp
mksquashfs lirc lirc2.tcz
moved this to /mnt/sda1/tce/optional, added it to onboot.lst.. restarted. i also tried tce-load -i and this said already installed. running simply 'lircd' didn't work, however i found there was an lircd in /daemons. Running '/daemons/lircd --driver=audio_alsa -d hw@48000' returned
Code: [Select]
Driver `audio_alsa' not supported.
Supported drivers:
        default
So, it seems i have compiled a version with even less supported drivers? ..again, i can't say i saw any options when compiling?

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 180
    • AmatCoder Projects
Re: LIRC w/ audio_alsa
« Reply #10 on: March 24, 2012, 02:10:23 PM »
Sorry for the delay in replying...

I did not use setup.sh to compiling LIRC, but I guess it is like :
Code: [Select]
./setup.sh -> 1 Driver configuration -> 3 Homebrew (soundcard input) -> 3 IR reciever connected to audio input using ALSA (EXPERIMENTAL)
Remember, you need alsa-dev.tcz for that!

Offline mb0

  • Jr. Member
  • **
  • Posts: 86
Re: LIRC w/ audio_alsa
« Reply #11 on: March 24, 2012, 04:30:21 PM »
OK, i have alsa-dev now. Setup.sh has very limited options under driver config.. (with transmitter diode/ software generates carrier/ Igor Cesko's variation... those as Y/N checkboxes.. that seems to be all.. i was expecting more).

I am not attached to using setup.sh.. just followed info that i've found. I am happy to follow your instruction if you will give it.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 180
    • AmatCoder Projects
Re: LIRC w/ audio_alsa
« Reply #12 on: March 26, 2012, 03:01:53 AM »
OK, i have alsa-dev now. Setup.sh has very limited options under driver config.. (with transmitter diode/ software generates carrier/ Igor Cesko's variation... those as Y/N checkboxes.. that seems to be all.. i was expecting more).

It seems that you miss some extension. Full list is:
Code: [Select]
git
compiletc
linux-headers-3.0.21-tinycore
Xorg-7.6-dev
alsa-dev
autoconf
automake
libtool
libtool-dev
intltool
bash
dialog

Run ./autogen.sh and then ./setup.sh ... Under driver configutation you should see this:



Offline mb0

  • Jr. Member
  • **
  • Posts: 86
Re: LIRC w/ audio_alsa
« Reply #13 on: March 26, 2012, 03:08:08 PM »
Thanks amat, missing bash was the culprit i think. Still working on getting it functional, but the install worked.