WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: custom kernel with old disks: Invalid device specified.  (Read 1133 times)

Offline theYinYeti

  • Full Member
  • ***
  • Posts: 165
    • YetI web site
custom kernel with old disks: Invalid device specified.
« on: March 22, 2012, 01:17:07 PM »
Hi. I compile a custom kernel for an old Toshiba 300CDS (ca. 1995 model) with a 2GB IDE drive.
Try as I might, I didn’t manage to get support for the IDE drive. I’m a little lost with the numerous options for drives.

So on boot, of course, neither /home nor /opt are found, or /tce for that matter.

The only hint I have toward making the drive being recognized is that TC4.3 did not recognize it, whereas TC4.4 does. And indeed, in the release notes, there is this phrase: “isa libata enabled for very old laptops”, which I guess is the important part for me.

But I was not able to find a working set of config options to match this release note  :(  Based on a diff from TC’s config from previous to current kernel, my last attempt was to set CONFIG_PATA_LEGACY=y, along with CONFIG_ATA_BMDMA=y, to no avail.

Any idea?

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4224
Re: custom kernel with old disks: Invalid device specified.
« Reply #1 on: March 22, 2012, 05:11:50 PM »
Hi theYinYeti
If you really feel the need to compile a kernel, rather than use TC4.4, I suggest you go to:
http://distro.ibiblio.org/tinycorelinux/4.x/x86/release/src/
Go to the kernel directory and download the 3.0.21 version of the config and linux files and use those as
a starting point.

Online curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7859
Re: custom kernel with old disks: Invalid device specified.
« Reply #2 on: March 22, 2012, 10:48:54 PM »
Maybe you're missing one of the generic options? But I agree with Rich, better start with a known-working config if you're not sure on what you need.
The only barriers that can stop you are the ones you create yourself.

Offline theYinYeti

  • Full Member
  • ***
  • Posts: 165
    • YetI web site
Re: custom kernel with old disks: Invalid device specified.
« Reply #3 on: March 23, 2012, 02:17:26 AM »
First, thank you for your replies. Actually, I did exactly as you suggest (it ran fine), and then proceded to slim the system down to Toshiba-only hardware (failure only).

Now, let me apologize too :( I’m really stupid sometimes, but then, such stripping of a kernel is new for me :/
My error was, that after checking for succes with my first attempts in a virtual machine, I kept testing in a VM for further attempts, when the kernel was limited to hardware found in the Toshiba 300CDS only!

From now on, I’ll test my kernels with the real hardware :D And I’ll let you know.

Yves.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4224
Re: custom kernel with old disks: Invalid device specified.
« Reply #4 on: March 23, 2012, 08:02:56 AM »
Hi theYinYeti
You are of course using  make menuconfig  or one of the other Linux configuration tools and not editing the config
file by hand. You may want to take a minute to read this too:
http://forum.tinycorelinux.net/index.php/topic,8717.msg47128.html#msg47128

Offline theYinYeti

  • Full Member
  • ***
  • Posts: 165
    • YetI web site
Re: custom kernel with old disks: Invalid device specified.
« Reply #5 on: March 25, 2012, 09:00:56 AM »
Hi Rich
I did know about these shortcomings of self-compiling the kernel :-) But I have just enough experience to see roughly what interacts with what, and as for the hardware, it won’t ever change. So, no problem :-)

Edit: I almost forgot! Disks are seen now. Now, I have to find out why I don’t have enough privilege to chmod /home/tc/* and set hostname. Must be because I tried setting my hostname directly instead of “box”. Well, that’s going too far anyway: I can always say “host=xxx” on boot :-)
« Last Edit: March 25, 2012, 09:02:51 AM by theYinYeti »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4224
Re: custom kernel with old disks: Invalid device specified.
« Reply #6 on: March 25, 2012, 09:15:19 AM »
Hi theYinYeti
Enter  sudo chown tc:staff /home/tc
See if chmod works now.
Add the  sethostname  command to your  /opt/bootsync.sh  file.