WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [solved] Mouse doesn't work  (Read 1547 times)

Offline logic_guy76

  • Newbie
  • *
  • Posts: 3
[solved] Mouse doesn't work
« on: March 14, 2012, 08:59:20 PM »
I downloaded TinyCore-current.iso and burned it to a CD.  The CD boots up and I get the TCL desktop.  However, the mouse doesn't work.  The mouse pointer doesn't move and I can't click on anything.  This is a standard 2-button mouse plugged into the PS/2 mouse port on the motherboard.  The mouse works fine on the same machine with Windows95, OS/2, DeliLinux, DSL, and various utility programs that I've booted.  Any suggestions?

Hardware:
Pentium MMX 200 MHz processor
Asus P/I-P55T2P4 motherboard
Intel 430HX chipset
Maxtor 6.2 GB disk drive
Matrox PCI video card
basic 2-button PS/2 mouse
standard 104-key PS/2 keyboard
« Last Edit: March 20, 2012, 06:55:34 PM by logic_guy76 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6580
Re: Mouse doesn't work
« Reply #1 on: March 14, 2012, 09:08:20 PM »
You could try <ctrl-alt-backspace> to get out of X and back to the console and then xsetup.sh, which should allow you to check and alter the mouse settings

Offline logic_guy76

  • Newbie
  • *
  • Posts: 3
Re: Mouse doesn't work
« Reply #2 on: March 14, 2012, 09:24:00 PM »
I tried that.  Selected PS/2 2-button mouse.  Typed startx to bringup the desktop again.  Still no mouse movement.

Offline xyz-worx

  • Newbie
  • *
  • Posts: 37
Re: Mouse doesn't work
« Reply #3 on: March 15, 2012, 12:38:56 AM »
Hi logic_guy76,

just take a look at this thread

http://forum.tinycorelinux.net/index.php/topic,10731.0/topicseen.html

I had the same problem on a very similar old machine - and I got it work!
Hope the same for you!

regards   xyz-worx

Offline logic_guy76

  • Newbie
  • *
  • Posts: 3
Re: Mouse doesn't work
« Reply #4 on: March 17, 2012, 01:39:47 PM »
Thanks, xyz-worx, for the pointer to that thread.  Lots of interesting information there.  Unfortunately, neither the acpi=off nor pci=noacpi boot options worked for me.  Your motherboard must be the ATX type.  Mine is even older, an AT type -- no software power supply control, I always have to hit the power button to turn it off.  However, I spent some time studying that link to the kernel parameters.  It seems that the PS/2 keyboard and mouse ports are controlled by an i8042 controller and there are several kernel parameters related to that.  I experimented with some of those and finally found one that paid off.  Kernel parameter i8042.noloop is the answer.  I added that to the boot options and the mouse moved!  Now I can finally start to explore Tiny Core's capabilities, which look quite interesting.

Offline OldAdamUser2

  • Full Member
  • ***
  • Posts: 199
Re: Mouse doesn't work
« Reply #5 on: March 17, 2012, 05:23:33 PM »
I had mouse problems when I upgraded to TC 3.8.2. I had to add the following to  my boot codes:

Quote
psmouse.proto=imps

I have almost no idea what that does or whether it could work for you, but your might give it a try.

Offline xyz-worx

  • Newbie
  • *
  • Posts: 37
Re: Mouse doesn't work
« Reply #6 on: March 19, 2012, 09:08:00 AM »
Hi logic_guy76,

I'm glad to hear, that you got your mouse working. When I read the post from OldAdamUser2,
one can imagine, that there are obviously dozens of kernel parameters to solve mouse problems
especially with old  motherboards.

Let's hope that all these parameters will survive with new kernels, that will come in the future.

BY the way:
Please mark your thread as 'solved'.  This will help other guys having similar problems.

Thanx and bye

xyz-worx