WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: gtk3 broken with Xorg 7.6  (Read 3213 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 7042
gtk3 broken with Xorg 7.6
« on: March 14, 2012, 04:24:53 PM »
Gtk3 and it's apps are broken with Xorg 7.6.  I one day will get around to fiddling with it, but for now the gtk3 apps can just be used with Xvesa.  I am not sure I will spend too much time right now with gtk3, but I will investigate.

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: gtk3 broken with Xorg 7.6
« Reply #1 on: March 14, 2012, 05:07:37 PM »
I've been saying that it was not my job:

http://forum.tinycorelinux.net/index.php/topic,12689.msg69321.html#msg69321

you know that I do cheering for you jason

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 7042
Re: gtk3 broken with Xorg 7.6
« Reply #2 on: March 17, 2012, 06:54:15 PM »
I tried building with Xorg running, made no difference.

I don't know what the issue is, either an issue with our build of Xorg (which works with everything else, also it is the latest Xorg release, so not likely the issue), or something about gtk3 or it's dependencies.

I will revisit one day in the future.

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Re: gtk3 broken with Xorg 7.6
« Reply #3 on: March 18, 2012, 11:25:48 AM »
Also I did both tests, with Xvesa and Xorg 7.5, but unfortunately nothing to do

Offline beroje

  • Full Member
  • ***
  • Posts: 122
Re: gtk3 broken with Xorg 7.6
« Reply #4 on: April 06, 2012, 05:55:25 AM »

tc@box:~$ gtester /apps/bin/l3afpad-bin

TEST: /apps/bin/l3afpad-bin... (pid=7695)
/apps/bin/l3afpad-bin: error while loading shared libraries: libgdk-3.so.0: cannot open shared object file: No such file or directory
FAIL: /apps/bin/l3afpad-bin
Terminated


tc@box:~$ gtester /apps/bin/emelfm2-gtk3-bin

TEST: /apps/bin/emelfm2-gtk3-bin... (pid=7698)
/apps/bin/emelfm2-gtk3-bin: error while loading shared libraries: libgdk-3.so.0: cannot open shared object file: No such file or directory
FAIL: /apps/bin/emelfm2-gtk3-bin
Terminated
tc@box:~$
tc@box:~$




tc@box:~$ gtester /apps/bin/l3afpad

TEST: /apps/bin/l3afpad... (pid=7768)
l3afpad: Unknown option --quiet
FAIL: /apps/bin/l3afpad
Terminated


tc@box:~$ gtester /apps/bin/emelfm2-gtk3

TEST: /apps/bin/emelfm2-gtk3... (pid=7772)
/apps/emelfm2-gtk3/bin/emelfm2-gtk3-bin: unrecognized option '--quiet'
/apps/emelfm2-gtk3/bin/emelfm2-gtk3-bin: invalid option -- '='
/apps/emelfm2-gtk3/bin/emelfm2-gtk3-bin: invalid option -- 'q'
usage: emelfm2 [option]
PASS: /apps/bin/emelfm2-gtk3
tc@box:~$
tc@box:~$

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 180
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #5 on: April 19, 2012, 12:24:20 PM »
Gtk3 and it's apps are broken with Xorg 7.6.  I one day will get around to fiddling with it, but for now the gtk3 apps can just be used with Xvesa.
I don't know what the issue is, either an issue with our build of Xorg (which works with everything else, also it is the latest Xorg release, so not likely the issue), or something about gtk3 or it's dependencies.

The "guilty" is libX11.so.0.6.3 from Xlibs.tcz...Was it compiled with some custom option?

To check it, you can do (with Xorg running):
Download: http://www.x.org/releases/X11R7.6/src/everything/libX11-1.4.0.tar.bz2
Untar and cd into
Code: [Select]
tc@box:~/libX11-1.4.0$ tce-load -iw compiletc Xorg-7.6-dev libxcb-dev  #compile dependencies
tc@box:~/libX11-1.4.0$ ./configure --prefix=/usr  # /usr because libX11 from Xlibs is into /usr/lib
tc@box:~/libX11-1.4.0$ make
tc@box:~/libX11-1.4.0$ sudo make install  # overwrite libX11

Then you can run gtk3 applications without problems...(Only tested with Xorg 7.6)
« Last Edit: April 19, 2012, 01:08:41 PM by AmatCoder »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 7042
Re: gtk3 broken with Xorg 7.6
« Reply #6 on: April 19, 2012, 01:24:19 PM »
Thanks for the find.  I don't maintain Xorg but maybe Curaga can perhaps test a rebuild and if this is the case perhaps update Xlibs.


Offline AmatCoder

  • Full Member
  • ***
  • Posts: 180
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #7 on: April 19, 2012, 03:11:30 PM »
Even easier: Since libx11-xcb.tcz has correct libX11.so files we can do:

Code: [Select]
tc@box:~$ tce-load -iw libx11-xcb
tc@box:~$ sudo ln -f -s /tmp/tcloop/libx11-xcb/usr/local/lib/libX11.so.6.3.0 /usr/lib/libX11.so.6.3.0
tc@box:~$ sudo ln -f -s /tmp/tcloop/libx11-xcb/usr/local/lib/libX11.so.6.3.0 /usr/lib/libX11.so.6
tc@box:~$ sudo ln -f -s /tmp/tcloop/libx11-xcb/usr/local/lib/libX11.so.6.3.0 /usr/lib/libX11.so

With this, we change symbolic links to point to libX11 from libx11-xcb instead from Xlibs.

And then we can do:
Code: [Select]
tc@box:~$ scm-load -iw l3afpad
tc@box:~$ l3afpad

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 7042
Re: gtk3 broken with Xorg 7.6
« Reply #8 on: April 19, 2012, 05:38:39 PM »
That is ok as a workaround but I will pm Curaga and see if he is interested in rebuilding libX11.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7766
Re: gtk3 broken with Xorg 7.6
« Reply #9 on: April 20, 2012, 12:31:01 AM »
Our libX11 is 1.3.6, a standard working build. It seems like gtk3 requires xcb (which libX11 starting 1.4.0 also requires).

I'm not willing to force-add that bloat to the base (Xlibs) just yet. As I see it now, it's 5.0 material.
The only barriers that can stop you are the ones you create yourself.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7766
Re: gtk3 broken with Xorg 7.6
« Reply #10 on: April 20, 2012, 12:40:04 AM »
Further check to the errors is that gtk3 seems to use Xlib from multiple threads, which is not really supported without xcb. Had it directly required XCB, it would've said so configure-time and saved some time :P.
The only barriers that can stop you are the ones you create yourself.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 180
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #11 on: April 20, 2012, 03:05:32 AM »
Our libX11 is 1.3.6, a standard working build. It seems like gtk3 requires xcb (which libX11 starting 1.4.0 also requires).
As far as I remember, 1.3.x series also require xcb (it needs explicit ./configure --without-xcb  to avoid xcb).
Therefore all others distros works with gtk3...They have a standard libX11 build.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7766
Re: gtk3 broken with Xorg 7.6
« Reply #12 on: April 20, 2012, 03:07:09 AM »
I define "requires" as in can't be built without. 1.3 series still could.
The only barriers that can stop you are the ones you create yourself.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7766
Re: gtk3 broken with Xorg 7.6
« Reply #13 on: April 20, 2012, 03:12:45 AM »
Response from irc.gnome.org #gtk+ is that gtk3 should still be working without xcb. I'll open a bug.

edit: https://bugzilla.gnome.org/show_bug.cgi?id=674465

Jason and others, please comment there with any requested info etc.

It also seems 3.4.0 is out, could anyone test it?
« Last Edit: April 20, 2012, 03:27:14 AM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 180
    • AmatCoder Projects
Re: gtk3 broken with Xorg 7.6
« Reply #14 on: April 20, 2012, 04:56:38 AM »
I define "requires" as in can't be built without. 1.3 series still could.
I understand...yes, with 1.4 xcb can not be avoided.

It also seems 3.4.0 is out, could anyone test it?
Yesterday I tried 3.4.1 -- No luck, same failure.