General TC > Programming & Scripting - Unofficial

gcc not working

(1/1)

jrm7262:
Hi all,

        Have just installed tc4 and the compiletc extention.

When I run ./configure it fails with:

     root@box:/mnt/sda1/keep/reaver-1.4/src# ./configure
     checking for gcc... gcc
     checking whether the C compiler works... no
     configure: error: in `/mnt/sda1/keep/reaver-1.4/src':
     configure: error: C compiler cannot create executables

Is the error in gcc or the src files?

Apologies for any stupidity in the question, I haven't compiled anything since college and that was quite some time ago.
Any guidance greatly appreciated, even if its - "read this ...."

Kindest regards
James

bmarkus:
Install libmpc.tcz and retry.

jrm7262:
hi bmarcus,

                  Thank you for your reply, unfortunately even with libmpc.tcz the same error persists.

Kindest regards
James

Juanito:

--- Quote from: jrm7262 on March 13, 2012, 02:22:40 AM ---     configure: error: C compiler cannot create executables

--- End quote ---

This error is often due to one of the extensions listed in compiletc.tcz.dep (and their deps in turn) being missing - it would be good to check that they are all there and loaded properly

Navigation

[0] Message Index

Go to full version