Off-Topic > SCM EXtensions

Audacity scm Bug Feedback

(1/3) > >>

SamK:
Download
When downloading links2 an error is reported in the wget window
--- Code: ---/usr/bin/scm-load: line 41: can't open /etc/sysconfig/icons: no such file
--- End code ---
Is this a known and common issue as it was also observed today when downloading Links2?


Starting
The app fails to start via the JWM menu.  In a terminal an error message is obtained:

--- Code: ---/audacity-1.3-bin: error while loading shared libraries: libtiff.so.3: cannot open shared object file: No such file or directory
--- End code ---
Missing graphics-lib-1?
   

Jason W:
Do you have wbar.tcz loaded?  Not doing so will result in that error.

Also, do you have the latest audacity-1.3.scm?  It works here, both icon, menu, and command line.

SamK:

--- Quote from: Jason W on March 12, 2012, 05:36:52 PM ---Do you have wbar.tcz loaded?  Not doing so will result in that error.
--- End quote ---
None of the systems I build use wbar.  It is unlikely that I am alone in this based upon it regularly being raised in the forum.  My understanding is that wbar is now a separate and optional package.  Is this incorrect?




--- Quote from: Jason W on March 12, 2012, 05:36:52 PM ---Also, do you have the latest audacity-1.3.scm?  It works here, both icon, menu, and command line.
--- End quote ---
Scm browser reports v1.3.  No pending updates.  Symptoms remain unchanged.
--- Code: ---/apps/audacity-1.3/bin/audacity-1.3
/audacity-1.3-bin: error while loading shared libraries: libtiff.so.3: cannot open shared object file: No such file or directory
--- End code ---

Separately installing and loading graphics-lib-1.tcz allows Audacity to start.
   
A thought...
This test rig is using OSS.  Is yours using ALSA?  If so is graphics-lib-1 a dependency of one of the installed ALSA packages?
   

Jason W:
Ok, I will test again tonight, maybe I overlooked something.

Jason W:
I am using OSS a bit with the scm's, and I try to build with support for both alsa and OSS when possible, and so far that has been possible.

I added the tiff dependency, as I use Icewm that is already installed via tcz's so I did not notice.  Thanks for finding.

Navigation

[0] Message Index

[#] Next page

Go to full version