WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: backup not auto restored [4.5.4] - [SOLVED]  (Read 831 times)

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
backup not auto restored [4.5.4] - [SOLVED]
« on: July 04, 2012, 12:46:38 AM »
Booting from CD with flash pendrive plugged into USB port, backup does not get restored unless bootcode "restore=" is stated.
« Last Edit: July 04, 2012, 11:36:04 PM by tinypoodle »
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 8030
Re: backup not auto restored [4.5.4]
« Reply #1 on: July 04, 2012, 03:42:56 AM »
Is this with waitusb, so that the stick is found?
The only barriers that can stop you are the ones you create yourself.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: backup not auto restored [4.5.4]
« Reply #2 on: July 04, 2012, 07:22:12 AM »
Yes.
"waitusb=4" has proven to work reliably well in combo with "restore=", while even with "waitusb=30" without stating the "restore=" code it always fails.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4289
Re: backup not auto restored [4.5.4]
« Reply #3 on: July 04, 2012, 07:43:06 AM »
Hi tinypoodle
Three possibilities come to mind:
1. Your backup file does not use the default mydata.tgz name.
2. Your backup file is not in the default tce directory.
3. Another mydata.tgz file is being found first somewhere else.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: backup not auto restored [4.5.4]
« Reply #4 on: July 04, 2012, 09:53:12 AM »
Hi tinypoodle
Three possibilities come to mind:
1. Your backup file does not use the default mydata.tgz name.
2. Your backup file is not in the default tce directory.
3. Another mydata.tgz file is being found first somewhere else.

1. It does.
2. Tried: sda1, sda1/tce, sda2, sda2/tce. All of them work when specified with bootcode "restore=", none of them work automatically.
3. Double checked and excluded by find(1).
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4289
Re: backup not auto restored [4.5.4]
« Reply #5 on: July 04, 2012, 04:23:01 PM »
Hi tinypoodle
If you use the tce= parameter to point to the pen drive, does it find it then?

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: backup not auto restored [4.5.4]
« Reply #6 on: July 04, 2012, 04:50:35 PM »
I am using "base", having a need to be able to remove the pendrive after boot, therefore "tce=" is definitely not an option.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4289
Re: backup not auto restored [4.5.4]
« Reply #7 on: July 04, 2012, 05:17:14 PM »
Hi tinypoodle
You don't have another mydata.tgz, but how about another tce directory? Short of a possible bug in TC, thats
the only other thing I can think of. Though I would have thought it would have come up sooner if it were a bug.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: backup not auto restored [4.5.4]
« Reply #8 on: July 04, 2012, 05:57:36 PM »
I do have other tce dirs, but they are renamed.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4289
Re: backup not auto restored [4.5.4]
« Reply #9 on: July 04, 2012, 06:11:58 PM »
Hi tinypoodle
Well, that's all I can think of. I'm afraid you'll have to wait for someone smart to help you.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7343
  • Founder Emeritus
Re: backup not auto restored [4.5.4]
« Reply #10 on: July 04, 2012, 11:13:37 PM »
Confirmed bug. The good news it is fixed. The bad news is that ibiblio is once again giving us some challenges, i.e., no disk space. Waiting for free space to update a bug fix.
10+ Years Contributing to Linux Open Source Projects.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: backup not auto restored [4.5.4] - [SOLVED]
« Reply #11 on: July 04, 2012, 11:35:26 PM »
Thanks a lot roberts! :)
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)