General TC > Remasters / Remixes - Unofficial

New remastering?

(1/2) > >>

I'm an old microcore user, and I'm used to the old 3.x version. Now, here's the thing, I can follow all the steps in the wiki and get a 3.x version remastered, it works fine. Problem is, if I follow the same steps for 4.x, I just can't get it to work for the life of me. I am willing to admit I may have gotten it wrong.

In my remastered microcore, I have added two tcz's and have them in my onboot.lst. That is fine, I have an edited startup script, that works as well, no problems. I can chuck "embed" into my isolinux.cfg, that's fine.

What I don't get is why I just cannot manage to do the same for 4.x? What has changed that I'm not understanding? Also, would it not be a good idea to perhaps update the wiki to 4.x, considering most the information is 3.x or even earlier based?

Also, why does it assume that if I am remastering a core, that I'm doing it inside tinycore? Hell no, I'm running Lubuntu. I'm trying to build a core up for work. I don't like the abundance of information on wiki that only applies if you are actually using TinyCore. I'm not, not am I interested. I tried booting up CorePlus from a CD, and then tried ezremaster, it didn't work.

My problem ends up being something about the ram, and then none of my extra extensions work. I also don't get why there is guides on combining gz files using cat, when the extensions aren't even in gz format. I mean, wouldn't it just be a hell of a better idea if you just put the tcz files in gz format to begin with? You know? What exactly is the purpose of the non-standard tcz / tce format? I mean, what benefit is there?

Don't get me wrong, this is a bloody good project, it's good for having nice small cores, which is what I want, I have a 9mb ISO which can boot and get onto the internet, with a fancy little ftpput command. Great stuff! This project is so needed in a world dominated by Windows and Dos based boot disks that don't even work anyways, and are bloated. God.

Did you try ezremaster.tcz from the repo, the official remastering tool? Maybe it is easier to get remastering done than doing it manually.

The same instructions apply to 4.x (zcat, cpio, etc) and the page is clear it can be done on any distro.

You haven't told us what is failing for you, in either your manual remaster or the ezremaster one. Let us call up our resident psychics to gather those details ;)

I apoligise, I attempted both manual and ezremaster, both failed. The point is, the same process done on both 3.x and 4.x works on 3.x and not 4.x. It has something to do with /etc/init.d/rcS I don't have the exact error in front of me, but, what happens is it either fails to log on, or it fails to do some of the initramfs stuff, extensions don't become loaded.

The process between 3.x and 4.x is different, it's a fact, for one, you have a tce directory in 3.x and in 4.x it's a cpe directory, right? That's a difference. I'm just saying that it might be good to at least have the wiki updated. I can't find any information on the differences between 3.x and 4.x.

Anyways, I am sorry for not having the exact error in front of me, that's kind of my fault on that one. When it didn't work, I was just rm -r tmp rofl.

There was a big change starting with v4.2. Please read the announcement post. Prior versions offered tinycore where inside the initrd were the X/GUI elements. Starting with 4.2 there is no such X/GUI elements in the initrd.

They were factored out and are offered as extensions. The tce directory remains the local writable directory for extensions.  A cde diectory was made as a means to have extensions on a non-writable device, cdrom, or isohybrid so that the factored out X/GUI could be offered and with many more choices. See CorePlus.

I believe ezremaster legacy is for prior versions. You should use the proper version of ezremaster depending on your version of core.

Of course, we promote to use the latest version for the many new features being offered.


[0] Message Index

[#] Next page

Go to full version