WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Installing Tinycore Plus v4.3.1 and E17 ends up with E17 options?Need help  (Read 935 times)

Offline picrard

  • Newbie
  • *
  • Posts: 7
Hallo I have a problem with my Tinycore an E17

I've installed it on my hard disk and after this reboot and installed e17.tcz, e17-dev.tcz ,e17-locale.tcz OnBoot.
(I had the hope that it would work with e17-dev.tcz ,e17-locale.tcz because befor my second try i left them both out,
and got some errors)

I have removed the wbar from the OnBoot and had used the noicons in the boot parameters.
But after this I had a screenshot like this:


What did I made wrong?, I can't choose anything on this screen, the E17 Animation on the bottom is running, but I can't click anything,
it doesn't moves on???

When I press Alt+Ctrl+F1 it shows me this up:


looks like there is no error, all is o.k., but what did I made wrong ??

many thanks for help and a reply..

aLex

sorry for the bad caps from my crt monitor ;)

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
I do not know if it has anything to do with the initial configuration, but I have something like a presentiment.
I try to attach the configuration of my e17, you have to decompress it in your home, do a backup and restart (you must do it from terminal).
p.s. you also install e-modules-extra.tcz for the reason that I do use it and you may return an error if you do not add.

Offline picrard

  • Newbie
  • *
  • Posts: 7
Thanx vinnie, it worked...

first of all I have installed e-modules-extra.tcz, e-modules-extra-dev.tcz, e-modules-extra-locale.tcz,
after a restart I had the same problem with my desktop.
So I extracted you config file in my home folder, after a restart E17 started up, some errors, but I had the chance to
deselect them for the next boot.

So here, that was the first change of you desktop:


Now it looks like that:


Now I have the chance to test the TinyCore with E17(I like this DE!)

Thank you!!!

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
I can not remember exactly after which update I had a similar problem with the same background green and red.
This happened when I was starting e17 with the option "no restore", I do not know if it's a problem to solve or even scaling of the background.

Since I do not happen at all, would be to understand the reason, I use e17 on a 10" netbook screen, also your screen seems small

Offline picrard

  • Newbie
  • *
  • Posts: 7
No, I use a 19" CRT monitor with this example,

after I've used your custom config files from your e.7z file, E17 started up with this big resolution,
I don't know what it was, maybe 800x600(???), I didn't checked it I was happy that E17 started up.

After the second start it showed me 1280x1024, for me it's a little bit to small.
But changing the resolution from the E17 settings was not so easy, it showed me
1280x1024, 1024x768 and 800x600 but with a syncfrequency 0Hz(??).
I have to change it in an other way, but I was not finished, I use a NVIDIA card,
so I have to install the NVIDIA driver, too. Then I will give it a try.

I have a second problems with my language/keyboard support. You have English keyboard in use,
I want to install the German keyboard settings, but that's not easy as it seems,
an adding of
Code: [Select]
loadkmap < /usr/share/kmap/qwertz/de-latin1-nodeadkeys.kmap in the /opt/bootlocal.sh made no effect and in the E17 setting I can't select another setting, there is nothing to select, do I have to edit the E17 setting manually?

If you have an solution for this, it would be great, I will maybe test it today later when I find some time, now I'm at work, using TinyCore on a USB stick running XFCE, it works great, but at home I would like to use E17.

At the moment it runs a little bit slow, maybe I have to change some settings.

I don't know why, but always I shut down the computer it shows me
<<<ENLIGHTENMENT ERROR>>> or something like that?

Offline floppy

  • Hero Member
  • *****
  • Posts: 577
with xvesa, I made
- load kmaps.tcz on boot
- use the boot code "kmap=qwertz/de-latin1"
then I have my DE keyboard running.
With Xorg, its different, I had to make the necessary setup in xorg.conf
Hopefully it helps.
AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline vinnie

  • Hero Member
  • *****
  • Posts: 1104
  • HandMace informatic works
Yep, for xvesa and prompt use the floppy istruction, for xorg personally i edit .xsession in my home, backup and reboot:

Code: [Select]
/usr/local/bin/Xorg -nolisten tcp &
export XPID=$!
waitforX || ! echo failed in waitforX || exit
"$DESKTOP" 2>/tmp/wm_errors &
export WM_PID=$!
[ -x ./.setbackground ] && ./.setbackground
setxkbmap it &
[ -x ./.mouse_config ] && ./.mouse_config &
[ $(which "$ICONS".sh) ] && ${ICONS}.sh &
[ -d ".X.d" ] && find ".X.d" -type f -print | while read F; do . "$F"; done

i think is "setxkbmap de &" for you, it is not necessary to download keymap.tcz for xorg layout.