General TC > Tiny Core Netbooks

CorePlus 4.3.1, Grub and Toshiba NB300



I’ve got a silly problem. It is probably something obvious, I did try to read the forums and Wiki before posting, but I can't see any related problem.

I have trying to enable Tiny Coreplus (4.3.1) on a Toshiba network, NB300. Already installed Windows 7 Starter and PCLinuxOS 2010. Works fine, if a bit slow, therefore I wanted TC to speed things up.

I have done a frugal install to a small partition, without the bootloader install, then manually pointed Grub (0.97) towards the partition with the following:

title Tiny Core
root (hd0,6)
kernel /tce/boot/vmlinuz
initrd /tce/boot/tinycore.g

Grub loads up and freezes after:

Root  (hd0,6)
 Filesystem type is ext2fs, partition type 0x83
kernel /tce/boot/vmlinuz
 [linux-bzimage, setup=0x3600, size=0x261c40]
initrd /boot/tinycore.gz

***at this point nothing*** It freezes.

The Live USB stick worked perfectly. I am mystified.

Does that grub section look OK? Or have I missed off something critical or silly?

I have used TC, off and on, since the early days, straight from the USB stick. Never needed to do a HD install. I am baffled why it doesn’t work.

I tried a various permutations and options on the kernel command line without any success.

Any suggestions?

Check in /boot and see if you have tinycore.gz.

Thanks Guy.

It was that line, but should have been /tce/boot/core.gz not tinycore.gz

All I need now is to point it at sda7 and make the apps permanent.



[0] Message Index

Go to full version