Tiny Core Extensions > TCE Tips & Tricks

HOWTO: DosBox

(1/4) > >>

gunny:
I ran into a problem starting DosBox and then getting the arrows keys to work on my old IBM ThinkPad.

When I tried to start DosBox nothing happened, so I opened terminal and ran dosbox from the command-line.

That returned the following error "error while loading shared libraries: libSDL_sound-1.0.so.1: cannot open shared object file: No such file or directory"

Searching the forum I found a post from marco which in part said "As it turns out the missing dependencies are: 'sdl-sound.tcz', 'libasound.tcz', and 'libvorbis.tcz'."

I loaded sdl-sound.tcz, libasound.tcz, libvorbis.tcz and DosBox opened.

The next problem I encountered was the arrow keys were not working.

The fix for this was to set usecancodes to false in the dosbox-0.74.conf file.

Afterwards I was able to install Windows 3.1 with sound, video and joy stick drivers.

Now my grandson can play some old school dos and windows games.

Tiny Core Linux Rocks!!!

Lee:
Thanks for the HOWTO.

I don't suppose you've tested that setup with Red Storm Rising or F19 Stealth Fighter?

Try this for screen shots w/o the terminal window showing:

--- Code: ---( screenshot.sh & ) ; exit
--- End code ---

vinnie:
I wanted to package dbgl time ago but did not succeed  :P

OldAdamUser2:
Thanks, gunny. Your tips really helped. I can now use the great DOS word processor--Norton Textra!

gunny:
Lee,

Thanks for the screenshot tip!  :)

I added the following to .jwmrc-keys
--- Code: newbielink:javascript:void(0); [nonactive] ---<Key mask="A" key="p">exec:screenshot.sh</Key>
--- End code ---

 

Navigation

[0] Message Index

[#] Next page

Go to full version