WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: perl xml parser  (Read 3279 times)

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
perl xml parser
« on: January 20, 2009, 12:08:24 PM »
I was trying to configure intltool-0-40.5, and got stuck on:

Code: [Select]
XML::Parser... configure: error: XML::Parser perl module is required for intltool
I've loaded perl5.tczl, perl_xml.tcz, and played around with exporting LD_LIBRARY_PATH, but no luck.
Is there a way to get this working?  Thanks

John

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10973
Re: perl xml parser
« Reply #1 on: January 20, 2009, 12:49:56 PM »
You shouldn't load both perl5 and perl_xml; it's possible that the configure script found the wrong one.

That aside, do you need 0.40? 0.35.5 is in autotools.tcz
The only barriers that can stop you are the ones you create yourself.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: perl xml parser
« Reply #2 on: January 20, 2009, 02:57:09 PM »
You shouldn't load both perl5 and perl_xml; it's possible that the configure script found the wrong one.

It seems to be looking at /usr/local/bin/perl, which is used for perl5.8.8. That didn't work, so I linked it to /usr/local/bin/perl15.10.0 which didn't work either. 

edit: actually, I think perl5.8.8  is put in /usr/bin....I'll try that.
edit2  That did the trick!!  Thanks

Quote
That aside, do you need 0.40? 0.35.5 is in autotools.tcz
  That might work, although I'd still like to know if there's something I should be doing differently.
Thanks

john
« Last Edit: January 20, 2009, 03:13:06 PM by jpeters »

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: perl xml parser
« Reply #3 on: August 11, 2009, 03:48:50 AM »
You shouldn't load both perl5 and perl_xml; it's possible that the configure script found the wrong one.

I just ran into a problem again with perl_xml, and revisited this thread. Perl5.tczl is a dependency for apps like cups, so it's likely to be loaded along with perl_xml. I found that perl_xml.tcz won't work, although perl_xml.tce will.  Are you saying that perl_xml can replace perl5 dependencies?  (if so, it's 3.6M lighter).
« Last Edit: August 11, 2009, 04:07:30 AM by jpeters »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14613
Re: perl xml parser
« Reply #4 on: August 11, 2009, 04:52:18 AM »
I made the perl_xml extension - basically perl plus the xml parser perl module - for compiling use. The perl5 (with shared lib) was intended for general use.

This being said, the perl_xml extension might well fit your needs.
« Last Edit: August 11, 2009, 08:51:54 AM by Juanito »

Offline junan

  • Jr. Member
  • **
  • Posts: 88
Re: perl xml parser
« Reply #5 on: August 11, 2009, 07:19:05 PM »
why not change cups dep file? change perl5 to perl_xml.
fun and fearless ...