Tiny Core Base > Micro Core

Core64 not booting into GUI (4.2)

(1/2) > >>

KHarvey:
I have finally been able to get Core64 (4.2) working by following the Wiki.  Except I haven't been able to get the GUI working yet.
I have installed Core64 using the grub-0.97-splash and pointing it to the core64.gz and vmlinuz64.
Here is what my menu.lst looks like

--- Code: ---default 0
timeout 10
title Core 64
root (hd0,0)
kernel /boot/vmlinuz64 quiet
initrd /boot/core64.gz tce=sda1

--- End code ---

In the beginning everything was booting fine.  I would come up to prompt and I could navigate and run commands.  I then decided that I wanted to install a GUI so that I could install the rest of my apps and this is where the problem begins.
I installed the following using ab:

--- Code: ---fltk-1.10.tcz
flwm_topside.tcz
wbar.tcz
Xlibs.tcz
Xprogs.tcz
Xvesa.tcz

--- End code ---

Now everytime I reboot and select Core 64 from my grub I come up to a black screen, and I am unable to do anything.  No response from the keyboard that I can tell, so I have to do a hard reboot, and then I have the same problem.  I tried installing Xorg and Fluxbox too, but still the same problem.
I did find though if I put my Core CD and boot to that it now boots to the GUI.  So there is obviously some configuration that I am missing.  That or the GUI isn't compatible with Core64.

I'm not sure where to go from here.  My main goal was to be able to take advantage of the 8 GB of memory I have in my computer for Virtual Machines in VirtualBox.  I think that Core64 is the only way to do that, but now I am stuck.

Any suggestions?

gerald_clark:
Xvesa does not support 64-bit.
Use Xorg.

KHarvey:
Thank you for the response.  Am I going to run into a lot of incompatible applications in Core64?

I have now uninstalled Xvesa and installed Xorg-7.6, but for some reason Xorg isn't unpacking on boot.  When I boot I go straight to the command line, but it doesn't appear the Xorg is being unpacked.  When I do a find / -name Xorg it comes back with zero results.  However if I boot using the CD then it boots into Fluxbox and Xorg just fine.  When I search for Xorg there it is found in /usr/local/bin/Xorg and /tmp/tcloop/Xorg-7.6/usr/local/bin/Xorg
When I check those locations at the CLI without the CD there is no /tmp/tcloop/Xorg-7.6/usr/local/bin there is only a lib folder in that directory.

gerald_clark:
First "tce-load -iw Xorg-7.6" then edit your onboot.lst and change Xvesa.tcz to Xorg-7.6.

genec:

--- Quote from: gerald_clark on January 06, 2012, 03:24:01 PM ---Xvesa does not support 64-bit.
Use Xorg.

--- End quote ---

Or if you need smaller at the expense of convenience (fully configured at boot time) and immense performance loss, you can also consider Xfbdev but that requires the Linux kernel framebuffer.

Navigation

[0] Message Index

[#] Next page

Go to full version