Tiny Core Base > Micro Core

Microcore in VirtualBox boot error

(1/1)

Wolftousen:
It's been a long while since I've updated microcore on my netbook, I think the version is 2.x, so i wanted to test out installing the newest version in virtual box first just to see how it performed.

I can get multicore to run and install microcore, but as soon as I restart without multicore disk mounted I get the following error:

"Fixing recursive fault but reboot is needed!" (preceded by a lot of hex...)

I changed around some settings and as soon as I switched it to use 1 processor instead of 2 or 4 (I have an 8 core amd am3+ processor 3.2ghz 8gb ddr3) I stopped getting the error message.  I tried installing tinycore and it runs just fine with any number of cores, but I have no desire for the bloat it adds and just want the true bare minimum that microcore provides.

Anyone have insight on why microcore fails when trying to give it more than 1 core?

I'm using VirtualBox 4.1.8 btw.

curaga:
Could be a Virtualbox bug. Perhaps try the multicore cd live? I recall it has micro as one of the boot options.

Wolftousen:
Unless i'm missing something in the boot options I see nothing that specifies to go into microcore vs tinycore, though you can install microcore once it's loaded.  I tried installing microcore from both the multicore and microcore iso and same error everytime.  I even got the iso for microcore 3.8.4 and while it didn't give the exact same error msg, it was very similar...

I've gone through absolutely every setting now and it's only the processor count being > 1 that causes it.

I'll try some older versions of virtualbox and try on my i7 laptop to see what happens, but it seems very odd to me that tinycore would work fine and not microcore.

Rich:
Hi Wolftousen
Boot Multicore, when the screen that reads "press F2, F3, F4 for help" comes up, type "mc' and
hit enter.

Wolftousen:
Ah, ok.

Doing that gives the same error message as if i were booting the regular microcore.iso.

However, after uninstalling 4.1.8 and install 3.2 the error no longer shows up, so it is something to do with Virtual Box and is not amd/intel specific.

Navigation

[0] Message Index

Go to full version