WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: fluxbox - startup-file doesn't load slitlist & background in 4.0.1  (Read 4642 times)

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1026
hi friends,

under 3.8.4 at the start of fluxbox i load the slitlist with my

~/.fluxbox/startup
#!/bin/sh
wmcpuload -bl -lc rgb:50/60/70 &
wmnd &
wmnet -w &
wmsmpmon &

it's controlled in my
~/.fluxbox/init
session.startupFile: ~/.fluxbox/startup
session.slitlistFile:   ~/.fluxbox/slitlist

when i use 4.0.1 with the same configuration, then the slitlist isn't automatically loaded,

to succeed i have to do it manually in a terminal...
tc@box:~$ .fluxbox/startup
then my slitlist is loaded and appears in fluxbox.

the second problem is that the background of my safed system style MerleyKay
is not loaded, instead of it the standard tinycore-wallpaper is displayed.
the rest of the system style is used.
after the restart of fluxbox in the fluxbox-menue the wallpaper of MerleyKay is properly displayed again.

~/.fluxbox/init
session.styleFile: /usr/local/share/fluxbox/styles/MerleyKay

i found no reason, why they are not loaded at the start of fluxbox in 4.0.1 anymore,
in 3.8.4 it still works.



« Last Edit: October 07, 2011, 02:08:04 AM by netnomad »

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1026
Re: fluxbox - startup-file doesn't load slitlist & background in 4.0.1
« Reply #1 on: October 07, 2011, 02:21:12 PM »
to succeed i have to do it manually in a terminal...
tc@box:~$ .fluxbox/startup
then my slitlist is loaded and appears in fluxbox.
i start now the fluxbox-startup-file in ~/.X.d/startup, unfortunately quick and dirty. :(
has someone a better solution?
i was used that it's loaded automatically by fluxbox.

but the background problem is not so nice:
Quote
the second problem is that the background of my safed system style MerleyKay
is not loaded, instead of it the standard tinycore-wallpaper is displayed.


Offline netnomad

  • Hero Member
  • *****
  • Posts: 1026
Re: fluxbox - startup-file doesn't load slitlist & background also in 4.0.2
« Reply #2 on: October 14, 2011, 09:52:55 AM »
i have still that annoying problem that sometimes the background of my safed system style MerleyKay
is not loaded, instead of it the standard tinycore-wallpaper is displayed.
with the command to restart the fluxbox session, the fluxbox-wallpaper can be loaded.
the slitlists i load over .xsession... uncommon way, quick and dirty...
« Last Edit: October 14, 2011, 09:57:09 AM by netnomad »

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1026
Re: fluxbox - sometimes standard background is loaded
« Reply #3 on: October 27, 2011, 12:52:02 PM »
has someone an idea why fluxbox sometimes load the standard tinycore background image
instead of the background of my loaded fluxbox style!?
every hint is appreciated!!!

thank you for your help!

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10960
Re: fluxbox - startup-file doesn't load slitlist & background in 4.0.1
« Reply #4 on: October 27, 2011, 11:18:43 PM »
If you use fluxbox's wallpaper setting, remove TC's: .setbackground
The only barriers that can stop you are the ones you create yourself.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1026
Re: fluxbox - startup-file doesn't load slitlist & background in 4.0.1
« Reply #5 on: October 29, 2011, 01:21:41 AM »
hi curaga,

thank you for your reply!
how do you want that i remove .setbackgroud?
f.e. with "rm /usr/bin/setbackground" in the bootlocal.sh?

i did heavy testing and realized that it has something to do with my .xsession entry:

version1
Code: [Select]
if [ -n "$BACKGROUND" ]; then
  setbackground full /opt/backgrounds/"$BACKGROUND"
else
  [ -x ./.setbackground ] && ./.setbackground
fi

and i changed it quick and dirty to

version2
Code: [Select]
if [ -n "$BACKGROUND" ]; then
  setbackground full /opt/backgrounds/"$BACKGROUND"
else
  sleep 1
fi

i don't like this solution, but if i delete the whole part then i get a ugly black background behind wbar
and i have to restart fluxbox to solve display problem.

thanks for every help.
« Last Edit: October 29, 2011, 03:08:38 PM by netnomad »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10960
Re: fluxbox - startup-file doesn't load slitlist & background in 4.0.1
« Reply #6 on: October 29, 2011, 02:31:40 AM »
Yes, I meant the ~/.setbackground file. If it doesn't exist, no changes in .xsession are needed.
The only barriers that can stop you are the ones you create yourself.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1026
Re: fluxbox - startup-file doesn't load slitlist & background in 4.0.1
« Reply #7 on: October 29, 2011, 03:06:30 AM »
now i understand that you mean the .setbackground-config-file in the home-dir...
i found and deleted it and changed my .xsession back to version1.

in this configuration i get the black background behind wbar, too.

do you have any recommendation?
« Last Edit: October 29, 2011, 03:18:06 AM by netnomad »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10960
Re: fluxbox - startup-file doesn't load slitlist & background in 4.0.1
« Reply #8 on: October 29, 2011, 04:40:32 AM »
Well, it's because wbar starts before a wallpaper has been set. Since you set the bg in fluxbox, you could move wbar start there too. Or, set the same wallpaper with the TC tool.
The only barriers that can stop you are the ones you create yourself.

Offline netnomad

  • Hero Member
  • *****
  • Posts: 1026
Re: fluxbox - startup-file doesn't load slitlist & background in 4.0.1
« Reply #9 on: October 29, 2011, 11:46:44 AM »
hi curaga,

thank you for your explanation.
now i understand and i can confirm that it's a kind of sequence problem,
the order of loading or the time gap between processes...
actually i didn't find a clean solution,
not with loading wbar in the ~/.fluxbox/startup,
not in my ~/.X.d/.startup or with the help of my .xsession.
so i stay in the moment with my stable, although quick & dirty, solution i mentioned above.

if you know clean solution, i appreciate every help.

thank you.
« Last Edit: October 29, 2011, 11:50:39 AM by netnomad »