WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Tiny Core v4.0  (Read 27089 times)

Offline floppy

  • Hero Member
  • *****
  • Posts: 577
Re: Tiny Core v4.0
« Reply #30 on: September 27, 2011, 11:48:59 AM »
few issues on my side (today status; mc4.0):
- error on boot now "hwclock: can t open dev/misc/rtc no such file or directory"; I use the bootcode TZ=....
- booting probably increased from 49 (3.8.4) to 51s (4.0) for my young PC.
  Perhaps this is coming from the boot code ide_core ignore_cable=1 which is nomore working.
  my second HDD (6GB) is nomore recognized as UDMA66 with this ide_core boot code.
  I will dig into this topic how to regain boot speed: perhaps making a non persistent home on this (now) UDMA33 drive,
  or play again with other boot codes. Im not sure of the test: perhaps I deleted the nozswap. I must have a look again at the box.
- usb_modeswitch.tcz missing
Change: the screen stay dark now without pci=use_crs. So, this is a mandatory boot code for me now.
If somebody has any idea how to improve the speed.. what boot code makes now a miracle.. ?
swap=sdc2 as boot code slow the pc: it seems that automatic swap detection (no boot code) is quicker.
AMD K6-IIIATZ 550MHz MB DFI K6xv3/+66
P4 HP DC7100 3GB 3GHz
Samsung NC10 boot from SD card port (via USB reader)
.. all TinyCore proofed

Offline egolipo

  • Newbie
  • *
  • Posts: 4
Re: Tiny Core v4.0
« Reply #31 on: September 27, 2011, 01:48:46 PM »
Sorry, multicore_4.0.iso got scrambled extensions. Corrected and reposted.
Thank You. TCL4.0 already up and running now!

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7904
Re: Tiny Core v4.0
« Reply #32 on: September 28, 2011, 07:18:18 AM »
What should I expect in term of memory impact and CPU usage by upgrading to TCL 4.0 ?

TC4 uses less ram at boot, more after; if you already used the embed bootcode, you'll only see the (slight) increase. CPU usage should not change measurably.
The only barriers that can stop you are the ones you create yourself.

Offline barbudor

  • Newbie
  • *
  • Posts: 17
Re: Tiny Core v4.0
« Reply #33 on: September 28, 2011, 08:22:44 AM »
Thanks Curaga.
I'll check and investigate about "embedd" boot code which I didn't know about.
At least, the great thing is how easy it is to try v4 and switch back in a minute to v3...
 :D
tinycore 3.8.3 on HP Thin Client T5300 (Transmeta Crusoe@533MHz, 56MB RAM, 2GB Compact Flash)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7904
Re: Tiny Core v4.0
« Reply #34 on: September 28, 2011, 08:48:48 AM »
The embed change was in 3.8.2, I see you're already on 3.8.3. If you do any measurements, please post them.
The only barriers that can stop you are the ones you create yourself.

Offline justauser

  • Newbie
  • *
  • Posts: 17
Re: Tiny Core v4.0
« Reply #35 on: September 28, 2011, 09:44:48 AM »
I downloaded the iso and then run a format and syslinux on my USB stick.  Copied over the tc* and boot directories and moved the syslinux.cfg and associate files to the root of the USB stick.  I labelled my USB drive "tce" and changed the syslinux.cfg to user LABEL="tce" where label="MultiCore" previously was.

After some exploration I found that the USB drive was actually labelled TCE and not tce.  I'd used Win7 to create and label the USB drive.  I think if you use Windows the drive label will be all uppercase, even if in Windows it is displayed in lowercase.  I would suggest that the base syslinux.cfg use all uppercase for the label.

Offline beerstein

  • Sr. Member
  • ****
  • Posts: 397
Re: Tiny Core v4.0
« Reply #36 on: October 01, 2011, 08:49:18 AM »
did somebody try to run the dillo2 resp. dillo3 browser?
Does it work with TCL4 ?
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3417
Re: Tiny Core v4.0
« Reply #37 on: October 01, 2011, 09:00:22 AM »
Did you try it yourself? Did you have a problem?

Offline beerstein

  • Sr. Member
  • ****
  • Posts: 397
Re: Tiny Core v4.0
« Reply #38 on: October 01, 2011, 11:16:13 AM »
I installed both (ver 2 and 3)
I got the icons in wbar but when I tried to click on it - no program start.
Then I installed minefield and served for a while and the screen froze.
TCL 3.XX worked on same machine ok
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3417
Re: Tiny Core v4.0
« Reply #39 on: October 01, 2011, 11:58:51 AM »
Both dillo 2 and 3 work for me.
You cannot install both at the same time, as they share some file names.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 1637
Re: Tiny Core v4.0
« Reply #40 on: October 01, 2011, 12:30:26 PM »
Can't help but notice how system performance has improved tremendously with v4.x   8)  Thx


I do wonder about the app search capability.  noted in an earlier post that apps can be searched for by typing in the first few letters of the extension name which functions well.  Only thing is many apps begin with unexpected letters or names;  take for example gpaint which used to be GNUpaint,  try searching for paint and see what happens...?

IIRC searching for the function of an extension would result in all the choices available,  not so in v4.x it seems;  try searching for browser, which results in zip!  I thought that was a positive feature of earlier versions??
 

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3417
Re: Tiny Core v4.0
« Reply #41 on: October 01, 2011, 12:39:13 PM »
Select 'Keyword' instead of 'Search'
I get 11 results, including gpaint.tcz.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 1637
Re: Tiny Core v4.0
« Reply #42 on: October 01, 2011, 12:53:10 PM »
Cool thanks,    See I didn't realize that option existed.  search works great now!!
Is keywords new?

have tried various searches and the features work well but I wonder how come the provides and keywords are not incorporated in search??  I can see how one might want to narrow the search, but initial searches?   just a thought.
« Last Edit: October 01, 2011, 01:00:25 PM by coreplayer2 »

Offline beerstein

  • Sr. Member
  • ****
  • Posts: 397
Re: Tiny Core v4.0
« Reply #43 on: October 02, 2011, 01:47:08 AM »
I will try dillo3 again - Thank you
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline miskor

  • Newbie
  • *
  • Posts: 4
Re: Tiny Core v4.0
« Reply #44 on: October 04, 2011, 12:33:51 AM »
I have a major problem with R6040 driver, it is broken in TC4!

In 3.8 it works normally... I've attached complete dmesg log, here is the end of it:

mii_bus 0 failed to register
r6040 0000:00:08.0: failed to register MII bus
r6040: probe of 0000:00:08.0 failed with error -22

I am using DMP eBOX-3300 mini-pc (with Vortex86 SoC) and I really beg you to fix this issue!

BR,
MiskoR