WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: 4.x repository status?  (Read 1122 times)

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
4.x repository status?
« on: September 16, 2011, 01:35:43 PM »
I'm wondering what is the status of the 4.x repository. How do we know which extensions have been verified to work correctly with 4.x or are we operating catch as catch can?
big pc man

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 4833
    • My Community Forum
Re: 4.x repository status?
« Reply #1 on: September 16, 2011, 02:53:22 PM »
Basically 4.0 is the same as 3.8 except kernel in this respect, so it is a safe assumption that programs compiled on 3.x for 3.x are working on 4.0

Kernel moduls are exceptions.
« Last Edit: September 16, 2011, 02:55:50 PM by bmarkus »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7803
Re: 4.x repository status?
« Reply #2 on: September 16, 2011, 09:39:12 PM »
Same as usual, please report anything broken.
The only barriers that can stop you are the ones you create yourself.

Offline mocore

  • Full Member
  • ***
  • Posts: 102
Re: 4.x repository status?
« Reply #3 on: September 17, 2011, 02:19:53 AM »
Same as usual, please report anything broken.

   
   not exactly broken just updated ,
   http://forum.tinycorelinux.net/index.php/topic,9536.msg52075.html#msg52075

      is adding  and older version that had been replaced   a possibility   
         
      i also wander how common is this kind of problem


Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 4833
    • My Community Forum
Re: 4.x repository status?
« Reply #4 on: September 17, 2011, 02:29:33 AM »
dubcore:

Referred thread is dated back to May. It has nothing to do with 4.x repo at all.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline mocore

  • Full Member
  • ***
  • Posts: 102
Re: 4.x repository status?
« Reply #5 on: September 17, 2011, 04:55:11 AM »


 http://distro.ibiblio.org/tinycorelinux/2.x/tcz/libnotify.tcz ( old pre 0.5 version of libnotify ) 
 http://distro.ibiblio.org/tinycorelinux/3.x/tcz/libnotify.tcz ( 0.5.2 )

 i guess im just asking if they can co exist in the  3.x / 4.x repo , eg as libnotify-4.9.tcz or something

 as the older pre 0.5 version is needed a dependency of an app i decided to try and build 
 the newer libnotify version works differently
 and appears incompatible with apps writen to used pre 0.5 libnotify

 

Offline danielibarnes

  • Hero Member
  • *****
  • Posts: 541
Re: 4.x repository status?
« Reply #6 on: September 17, 2011, 06:49:50 AM »
Although I submitted the original extension, I did not update it to 0.5.2. I can rebuild 0.4.5 for 3.x and submit it as libnotify-045 for apps which depend on the old library. I don't recall seeing the thread in May, but I can address it now.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 7074
Re: 4.x repository status?
« Reply #7 on: September 17, 2011, 07:30:22 AM »
This reminds me to mention:  The differences in the 3.x and 4.x repo are growing by the day, and it is very important that each submission is specified as to what repo it is for, 3.x, 4.x or both.  Some folks are doing this and some are not.  I can pretty well examine and tell what repo an extension is for, most built on 3.x will work on both, but I believe libxft.tcz for one is no longer needed in 4.x for example, so dep files are going to be different for each repo.

So please specify which repo a submission is targeted for when mailing in.  Thanks.


ali

  • Guest
Re: 4.x repository status?
« Reply #8 on: September 17, 2011, 08:03:39 AM »
dubcore:

Referred thread is dated back to May. It has nothing to do with 4.x repo at all.
the problem still applies :P