WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: How to disable autologin bootcode.  (Read 2997 times)

Offline solorin

  • Full Member
  • ***
  • Posts: 184
How to disable autologin bootcode.
« on: April 13, 2012, 05:49:44 PM »
Hi,

Maybe this is a bit too tinfoil hat but I would like to disable the autologin feature entirely. I've used the noautologin bootcode up until now.

Which are the relevant lines in the init scripts (or elsewhere) to change or comment out?

cheerio,
solorin
. . . if you don't know, now you know. . .
        ----- R.I.P. Biggie Smalls -----

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4189
Re: How to disable autologin bootcode.
« Reply #1 on: April 13, 2012, 06:01:58 PM »
Hi solorin
/etc/init.d/tc-config  would be a good place to start. Search for occurrences of  NOAUTOLOGIN.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: How to disable autologin bootcode.
« Reply #2 on: April 13, 2012, 06:07:29 PM »
Add the following line to /opt/bootsync.sh

echo "booting" > /etc/sysconfig/noautologin

Then do a backup.

Offline solorin

  • Full Member
  • ***
  • Posts: 184
Re: How to disable autologin bootcode.
« Reply #3 on: April 13, 2012, 11:58:43 PM »
Thx both.
@gerald_clark. You're a wizard!

Followup.
Does this work for setting boot options across the board?
Or are there execptions? What about ones that take an argument?
« Last Edit: April 14, 2012, 12:11:32 AM by solorin »
. . . if you don't know, now you know. . .
        ----- R.I.P. Biggie Smalls -----

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7768
Re: How to disable autologin bootcode.
« Reply #4 on: April 14, 2012, 01:39:27 AM »
Quote
Does this work for setting boot options across the board?

No. Only some specific ones check the files.
The only barriers that can stop you are the ones you create yourself.

Offline TinyToni

  • Newbie
  • *
  • Posts: 2
Re: How to disable autologin bootcode.
« Reply #5 on: November 19, 2012, 06:07:35 PM »
hello,

this topic seems to be the closest to my problem,
how can i make tinycore run as root so i can edit files
owned by root ? when i use sudo xfw it says : don't run this as root  ???

it would be the best option to simply run my system as root, because i will back it up
very often, it's no problem to restore it, if i make a mistake.

i only have bootlocal.sh in my opt folder.

Offline Lee

  • Hero Member
  • *****
  • Posts: 565
    • My Core wiki user page
Re: How to disable autologin bootcode.
« Reply #6 on: November 19, 2012, 07:09:16 PM »
Hi TinyToni,

Welcome to the TC forums.

As some business guru once said, "Don't try to learn the tricks of the trade.  Learn the trade.  The tricks will come along on their own."

Same with Linux.

Do not run your system as root.  There are actual good reasons to not do so.  Everyone (myself included) initially wants to run as root - and generations of Unix/linux users and admins have realized they should not normally do so.

Having said that, There are several ways it can be done and it will be a learning experience figuring them out - hopefully a long enough one that you will have learned not to do it by the time you learn how to do it.

And having said -that-, lets help you to not need to run as root....

First, after I install xfw, it runs under sudo without complaining.  I don't know why it would refuse to run for you with sudo but the message "don't run this as root" looks like what tce-load says when you try to run it as root - so I wonder... did you have xfw installed ondemand?  I don't use ondemand myself, but I suppose it must invoke tce-load the first time you run an ondemand program?  Anybody have experience with this?

If I'm right, just try running xfw as a regular user once to get it fully installed before trying to run it with sudo.

If that works then you will be able to edit files using sudo xfw

Lastly, re. just one file in /opt - open a terminal and run this command:
Code: [Select]
ls -l /opt
Then run this one:
Code: [Select]
ls -la /opt
The files whose names begin with a dot are "hidden" files - not shown by ls unless you explicitly ask to have them shown with the -a flag.
32 bit core4.7.7, Xprogs, Xorg-7.6, wbar, jwm
PPR, data persistence through filetool.sh
USB Flash drive, one partition, ext2, grub4dos

Offline TinyToni

  • Newbie
  • *
  • Posts: 2
Re: How to disable autologin bootcode.
« Reply #7 on: November 20, 2012, 03:43:08 AM »
Hello Lee,

thanks for your extensive reply. You have been absolutely right, i am running xfw on demand, and as soon as i used it as normal user, i could run it with sudo. Finally i can edit files as root  ;D

I am rly impressed by TinyCore, it's simple and quick, i really have to learn some things about it.
« Last Edit: November 21, 2012, 03:46:55 AM by TinyToni »