WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Clock initialization problems in VMWare  (Read 1757 times)

Offline barbudor

  • Newbie
  • *
  • Posts: 17
Clock initialization problems in VMWare
« on: September 08, 2011, 11:50:22 PM »
Hi

I am using a vmware TinyCore to develop software for my "embedded" microcore.

Unfortunately I has a clock setting issue when my TCL-VM starts.

I have the proper tz= setting for my TZ in TinyCore boot line. (France, tz=CET-1CEST,M3.5.0,M10.5.0/3)
This works fine with the "embedded" microcore.

But when my TCL-VM boots, the clock is initialized in a way that it consider my host-PC localtime to be gmtime.
So localtime in the TCL-VM is wrong.

I have not been able to install OpenVmWareTools.

Any idea on how I might solve this and get the right time ?

Thanks

~barbudor

tinycore 3.8.3 on HP Thin Client T5300 (Transmeta Crusoe@533MHz, 56MB RAM, 2GB Compact Flash)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7903
Re: Clock initialization problems in VMWare
« Reply #1 on: September 08, 2011, 11:53:46 PM »
"noutc", IIRC. Note that if the clock is not set from UTC time, the TZ string is useless and you won't get automatic DST changes.
The only barriers that can stop you are the ones you create yourself.

Offline barbudor

  • Newbie
  • *
  • Posts: 17
Re: Clock initialization problems in VMWare
« Reply #2 on: September 09, 2011, 12:44:36 AM »
Hi Curaga

Thanks. This is perfectly understood.

But this is what I want to solve : to get VMWare to properly initialize virtual-hardware-clock to GTIME and not to LOCALTIME.

I believe that this is more a VMWare question than a Linux question.
I can't find any setting in VMWare and I wonder if trying to get OpenVMWareTools installed and working would solve this.

TIA

~barbudor
tinycore 3.8.3 on HP Thin Client T5300 (Transmeta Crusoe@533MHz, 56MB RAM, 2GB Compact Flash)

Offline maro

  • Hero Member
  • *****
  • Posts: 1228
Re: Clock initialization problems in VMWare
« Reply #3 on: September 09, 2011, 01:54:44 PM »
Well, as a suggestion out of left field: You could always use VirtualBox instead of VMWare which has a setting to enable "Hardware clock in UTC time".

I personally have stopped working with VMWare products as they are not open source and way more "bloated" then the alternatives. In my (non-exhaustive) comparison I failed to find any significant reasons (e.g. speed, features, ...) to stay with what I considered once to be a truly great product. But you might have your reasons why you want to make your life more difficult then IMHO it has to be ...

Offline barbudor

  • Newbie
  • *
  • Posts: 17
Re: Clock initialization problems in VMWare
« Reply #4 on: September 10, 2011, 01:40:30 AM »
Hi Maro

This is still a good suggestion to point VirtualBox.
Indeed I am still using vmware because I started with their 1st  VmWare Player that was (I believe so) the first free VM, before VirtualBox and not including buggy VirtualPC.
I was too lazy to switch up to now, but maybe it's time now. Especially if I can find a way to migrate easily my VM to VirtualBox.


I also had a look to TCL boot command settime but apprently this one is deprecated.
For now I have partially solved my problem using ntpclient in my bootsync.sh (I had to figure that ntpclient.tcz have to be one of the first tcz in my onboot.lst to work properly ...  :o )

Thanks

barbudor
tinycore 3.8.3 on HP Thin Client T5300 (Transmeta Crusoe@533MHz, 56MB RAM, 2GB Compact Flash)