WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Tiny/Micro v.3.8 & v.3.8.1 with alsa  (Read 3351 times)

Offline MiniQ9

  • Newbie
  • *
  • Posts: 48
Tiny/Micro v.3.8 & v.3.8.1 with alsa
« on: August 13, 2011, 04:07:03 AM »
Alsa is not loaded with intel hd audio.
Rollback to v.3.7 solve problem.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7344
  • Founder Emeritus
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #1 on: August 13, 2011, 05:28:22 AM »
v3.8 and above uses busybox depmod. GNU depmod has been moved to extensions, depmod.tcz, and may be required by certain extensions, e.g., alsa.
« Last Edit: August 13, 2011, 05:42:50 AM by roberts »
10+ Years Contributing to Linux Open Source Projects.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 1601
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #2 on: August 13, 2011, 09:30:57 AM »
I have a really old system here running 3.8.1 and alsa without issue :)

Offline MiniQ9

  • Newbie
  • *
  • Posts: 48
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #3 on: August 14, 2011, 01:32:53 AM »
I have a really old system here running 3.8.1 and alsa without issue :)
key phrase
intel hd audio.

v3.8 and above uses busybox depmod. GNU depmod has been moved to extensions, depmod.tcz, and may be required by certain extensions, e.g., alsa.
Checked, did not help

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 1601
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #4 on: August 14, 2011, 06:08:39 AM »
How about OSS ?

Offline MiniQ9

  • Newbie
  • *
  • Posts: 48
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #5 on: August 14, 2011, 09:28:17 AM »
have not tried OSS, just rolled back to 3.7

Offline organharry

  • Newbie
  • *
  • Posts: 3
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #6 on: August 15, 2011, 12:53:28 PM »
Hello everybody,

I have the same problem with tc 3.8.1 and alsa and donĀ“t want to switch back to tc.3.7. Are there any tricks to get alsa to work with tc 3.8?

Greetings, organharry

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7344
  • Founder Emeritus
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #7 on: August 15, 2011, 02:30:23 PM »
I just checked the depmod.tcz in the repository and it was missing it's startup script.
I have uploaded the correction. Alsa requires depmod.tcz, alsa.tcz.dep file has also been adjusted to indicate such.
10+ Years Contributing to Linux Open Source Projects.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4210
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #8 on: August 15, 2011, 02:40:50 PM »
Hi roberts
I just called up AppBrowser. When I clicked on the Size tab for Alsa.tcz it reports  Error, not found
for the  depmod.tcz  entry.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7344
  • Founder Emeritus
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #9 on: August 15, 2011, 03:16:18 PM »
Thanks Rich. Should be a depmod.tcz.tree file now, which provides the size info.
10+ Years Contributing to Linux Open Source Projects.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4210
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #10 on: August 15, 2011, 03:19:38 PM »
Hi roberts
I'm afraid I found two more.  alsa-oss.tcz  and  alsa-plugins.tcz  both report the same error for
alsa-config.tcz

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7344
  • Founder Emeritus
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #11 on: August 15, 2011, 10:25:20 PM »
I have repopulated the whole forest. Should not be any missing trees. Thanks again for the heads up.
10+ Years Contributing to Linux Open Source Projects.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4210
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #12 on: August 15, 2011, 10:39:02 PM »
Hi roberts
Maybe I'm doing something wrong, but the size tab reports   Error, not found   for
alsa-driver-2.6.33.3-tinycore.tcz   and   depmod.tcz   for the alsa extensions.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7344
  • Founder Emeritus
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #13 on: August 16, 2011, 06:39:07 AM »
Perhaps you are using a mirror? Anyway this has nothing to do with the base and therefore has drifted off topic. If needed it should be continued in the extension area of the forum. To recap: The base now uses busybox depmod applet and the full gnu depmod, which may be required (alsa), is available as the extension, depmod.tcz.
10+ Years Contributing to Linux Open Source Projects.

ali

  • Guest
Re: Tiny/Micro v.3.8 & v.3.8.1 with alsa
« Reply #14 on: August 22, 2011, 04:41:47 AM »
i just decided to try tinycore again and 3.8's alsa fails to detect any sound card, 3.6 however works