Tiny Core Extensions > TCE Q&A Forum

wget: error while loading...libssl.so.0.9.8

(1/1)

commuter:
The appbrowser stopped having the capability to download extensions.  I'm getting the following error and I'm not sure how to fix it:

wget: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

I have tc installed to my HD for about a week.  The internet connection is still good.  I manually DLd openssl-0.9.8h.tcel and tried to use appbrowser to install it, but I still got the same error. 

Any help appreciated. ???
Commuter

tobiaus:

--- Quote from: commuter on April 09, 2009, 08:42:32 AM ---I manually DLd openssl-0.9.8h.tcel and tried to use appbrowser to install it, but I still got the same error. 

--- End quote ---

try downloading openssl-0.9.8h.tcel manually again, md5sum it from the command line, check against http://distro.ibiblio.org/pub/linux/distributions/tinycorelinux/tce/openssl-0.9.8h.tcel.md5.txt and rename it to openssl.tcel then: tce-load openssl.tcel from the command line.

Jason W:
Use tce-load to install openssl-0.9.8h.tcel.  You shouldn't have to rename it. Wget.tce will not work without the openssl extension. 

Downloading extensions directory with a web browser and installing them one by one is seeming to be the cause of the dependency issues I am reading about today.  It is much better to just use the appbrowser to fetch and install extensions as dependencies are resolved that way automatically, unless you just need one extension and are aware of the dependencies it will require.

commuter:
I tried
tce-load openssl-0.9.8h.tcel
and I tried it after a name change, but I was still getting the error from appbrowser.

My solution was to delete all files from my tce and tce/optional directory then rebooted.  Then appbrowser worked and I reinstalled the apps I wanted.  It seems odd to me that deleting files solved a problem that caused appbrowser to error that a file was missing.  But hey, I'm just a user.

I beleive, but can't be sure that my problem started when I was trying to get flash to work with Opera. :-\

I do appreciate the quick responses I received to my question.

Commuter

Jason W:
commuter-
I will check more into the wget extension as I have had issues with it not running once on my file server, though it normally has worked on my desktop.  If the wget extension has issues with loading and operation then it will interfere with the appbrowser or anything else that uses wget.  And that is no small issue.  I will make sure everything is ok with it.

Navigation

[0] Message Index

Go to full version