General TC > Tiny Core on Virtual Machines

virtualbox additions

(1/5) > >>

gigitek:
Hello all,

I've just installed virtualbox additions on my tiny core Vm. I don't have mouse integration, the window/desktop doesn't resize etc. As if they are not installed at all.

I'm using virtualbox 4.0.10 on a vista machine.
I've also tested on a windows 7. It's the same.

Suggestions?

Thank you.

coreplayer2:
I'm using VB 4.0.1r73009 on Windows7  which works great but initially had some issue,  I think the trick is don't install the Additions and disable mouse integration (Right Ctrl + I)

much easier to use this way.    click inside the window for capture and Right Ctrl + I to escape to the desktop
;)

andrewb:
I can report the same problem with tc running in VB 3.0.2 on WinXP. In the help document for VB it states:

--- Quote ---Linux or Solaris/OpenSolaris guests with an X.org server version 1.3 or higher[11] (support added with VirtualBox 1.6). The exception is Fedora 9, due to a bug in its X server.

--- End quote ---

The bug is not explained. Could be that the same issue is affecting tc.

david13lt:
I just started testing TinyCore Linux unter VirtualBox (4.1.2), but the mouse support is so terrible. I found several forum threads regarding the problems with VBox Additions, but I didn't have success making it work. Are these problems already resolved?

Toshick:

--- Quote from: david13lt on October 03, 2011, 01:28:31 AM ---I just started testing TinyCore Linux unter VirtualBox (4.1.2), but the mouse support is so terrible. I found several forum threads regarding the problems with VBox Additions, but I didn't have success making it work. Are these problems already resolved?

--- End quote ---

How did you install GA?

I've spend a week installing GuestAdditions 4.1.2 on TCL 4.x.
All threads I've found was related either TCL 3.x and below or GA of versions 3.x.x.
Solutions provided by Kingdomcome, for example, is not works for me.

I was successful in building and installing GA on my TCL box. I've made an extension where I've put all files was changes during install (i've did like in script, but manually). This extension should load on Boot. But during boot and extension load I have next messages:
udevd[71]: specified user 'vboxadd' unknow.
When my system boots up, vboxguest module is not loaded. As I understand - extension been loaded before /opt/.filetool.lts invoked. So, add /etc/group, /etc/passwd, and /etc/shadow to filetool.lst is not helps.

Please help me to solve this, because I'm new to TCL too.

Navigation

[0] Message Index

[#] Next page

Go to full version