WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)  (Read 1524 times)

Offline pme127

  • Newbie
  • *
  • Posts: 19
TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)
« on: July 16, 2011, 01:04:25 AM »
TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)

Loading TCL is not a once only event, the method changes (almost) with each update!

The method used to load TCL 3.6 (hybrid) using the iso file, doesn't work with 3.7 specifically, "mount /mnt/hdc" returns "no hdc found" (or words to that effect). Similarly, the starter pack doesn't work at all.

I set up a new VDI in VB and partition/format it (ext4) with Parted Magic, joining your instructions at "mount /mnt/sda1" having all ready loaded grub-0.79-splash.tcz and making terminal root with "sudo su".


I am writing this in frustration/desperation, I dread each new update!

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 7858
Re: TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)
« Reply #1 on: July 16, 2011, 01:47:48 AM »
You don't need to do a reinstall to update. Once your bootloader etc are in place, just download the latest tinycore.gz and kernel. The wiki is more precise on that.
The only barriers that can stop you are the ones you create yourself.

Offline pme127

  • Newbie
  • *
  • Posts: 19
Re: TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)
« Reply #2 on: July 16, 2011, 08:28:50 AM »
You don't need to do a reinstall to update. Once your bootloader etc are in place, just download the latest tinycore.gz and kernel. The wiki is more precise on that.

Thank you for your reply, and I will try out the options in the Wiki, but my point was that I wanted to do a new clean install (using the method that worked for TCL 3.6) in a new 3.7 Virtual Machine, and when 4.0 arrives I will want to do the same.

Offline pme127

  • Newbie
  • *
  • Posts: 19
Re: TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)
« Reply #3 on: July 17, 2011, 02:15:01 AM »
I have downloaded MCL 3.7.1.iso to USB external hard disk (NTFS), put that as CD in VM TCL 3.7 and started VM, all OK.

I have followed the Wiki for install on Hard Disk albeit a virtual hard disk already partitioned ext4 and linux swap, all goes well until the finish, when I get "Error message failed to mount USB device" (or words to that effect), this is the same USB device it has been running from up till now.

I tried it with MCL directly on OS X but VB didn't like it! No start VM. It seems the installer is more fussy than TC.

I suspect VB Extensions for TCL would solve the problem, but that's way beyond me.

Offline TheNewbie

  • Newbie
  • *
  • Posts: 42
Re: TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)
« Reply #4 on: July 20, 2011, 03:14:05 AM »
Why do you insist on doing a HDD install? By default, every time TC boots, it reloads the extensions and files contained in the 'tce' directory.

Really, all you need to do, if your desire is to run TC without keeping the ISO loaded as a bootable CD, is just put the ISO, bootloader, and tce directory all inside the virtual drive. (See wiki for information on the bootloader and 'persistence')

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 6377
Re: TCL in VirtualBox 4.0.6 on OS X (Snow Leopard)
« Reply #5 on: July 20, 2011, 03:22:28 AM »
By default, every time TC boots, it reloads the extensions and files contained in the 'tce' directory.

No, it only loads the extensions in /tce that are listed "onboot"